aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes/package_ipk.bbclass
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2013-02-04 23:06:52 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-06 09:35:01 +0000
commitcf0aa9c4fdae8855803e96b1922d54a2431795d3 (patch)
treee3e5cfed064f7243885c8e8a57779dbfa5a287b7 /meta/classes/package_ipk.bbclass
parent8abcf2c3541d7fe96d7717cb161812784dca6c66 (diff)
downloadopenembedded-core-contrib-cf0aa9c4fdae8855803e96b1922d54a2431795d3.tar.gz
ipk: use OPKGLIBDIR in all places
* it's not recommended to change this value, because it breaks upgrade path on target (all old u-a alternatives are forgot in old OPKGLIBDIR value * but make it consistent, so if someone really want to change that, then setting OPKGLIBDIR_distro in distro.conf would be enough * without this there were at least 4 places to change: rootfs_ipk: opkglibdir variable (notice that I've removed /opkg from it to correspond with EXTRA_OECONF option used in opkg recipes package_ipk: ${target_rootfs}${localstatedir}/lib/opkg/ hardcoded in package_install_internal_ipk opkg-collateral: value in lists file opkg: EXTRA_OECONF for all 3 classes, FILES_libopkg, do_install * validated with buildhistory that without OPKGLIBDIR explicitly set the output is the same and that after setting OPKGLIBDIR_forcevariable := "${libdir}" everything including empty directory from package_ipk is moved to libdir Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta/classes/package_ipk.bbclass')
-rw-r--r--meta/classes/package_ipk.bbclass4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/classes/package_ipk.bbclass b/meta/classes/package_ipk.bbclass
index 433d0bbe88..e46a52a022 100644
--- a/meta/classes/package_ipk.bbclass
+++ b/meta/classes/package_ipk.bbclass
@@ -12,6 +12,8 @@ OPKGBUILDCMD ??= "opkg-build"
OPKG_ARGS = "-f $INSTALL_CONF_IPK -o $INSTALL_ROOTFS_IPK --force_postinstall --prefer-arch-to-version"
+OPKGLIBDIR = "${localstatedir}/lib"
+
python package_ipk_fn () {
d.setVar('PKGFN', d.getVar('PKG'))
}
@@ -138,7 +140,7 @@ package_install_internal_ipk() {
local package_to_install="${INSTALL_PACKAGES_NORMAL_IPK}"
local package_multilib="${INSTALL_PACKAGES_MULTILIB_IPK}"
- mkdir -p ${target_rootfs}${localstatedir}/lib/opkg/
+ mkdir -p ${target_rootfs}${OPKGLIBDIR}/opkg
local ipkg_args="${OPKG_ARGS}"