aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes/package_ipk.bbclass
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-06 11:38:59 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-07 17:09:40 +0000
commit5e482b278c3775b0acecc621cf2d3b90ee516f26 (patch)
tree0107cbe347fa72a7d239a4b0efd640bc01df75a7 /meta/classes/package_ipk.bbclass
parent2ee979ff71d31e497be856ea1443667c6d799d34 (diff)
downloadopenembedded-core-contrib-5e482b278c3775b0acecc621cf2d3b90ee516f26.tar.gz
rootfs_ipk/package_ipk: Simplify opkg commandline option variables
The current maze of IPKG_ARGS variables is hard to understand and worse, not even used in some places. This simplifies the code and specifies the options in one place. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/package_ipk.bbclass')
-rw-r--r--meta/classes/package_ipk.bbclass7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta/classes/package_ipk.bbclass b/meta/classes/package_ipk.bbclass
index f916cf5b90..b441e86c0a 100644
--- a/meta/classes/package_ipk.bbclass
+++ b/meta/classes/package_ipk.bbclass
@@ -10,6 +10,8 @@ PKGWRITEDIRIPK = "${WORKDIR}/deploy-ipks"
# Program to be used to build opkg packages
OPKGBUILDCMD ??= "opkg-build"
+OPKG_ARGS = "-f $INSTALL_CONF_IPK -o $INSTALL_ROOTFS_IPK --force_postinstall --prefer-arch-to-version"
+
python package_ipk_fn () {
d.setVar('PKGFN', d.getVar('PKG'))
}
@@ -71,7 +73,7 @@ package_tryout_install_multilib_ipk() {
multilib_tryout_dirs=""
for item in ${MULTILIB_VARIANTS}; do
local target_rootfs="${MULTILIB_TEMP_ROOTFS}/${item}"
- local ipkg_args="-f ${INSTALL_CONF_IPK} -o ${target_rootfs} --force_overwrite"
+ local ipkg_args="${OPKG_ARGS}"
local selected_pkg=""
local pkgname_prefix="${item}-"
local pkgname_len=${#pkgname_prefix}
@@ -127,7 +129,6 @@ split_multilib_packages() {
package_install_internal_ipk() {
local target_rootfs="${INSTALL_ROOTFS_IPK}"
- local conffile="${INSTALL_CONF_IPK}"
local package_attemptonly="${INSTALL_PACKAGES_ATTEMPTONLY_IPK}"
local package_linguas="${INSTALL_PACKAGES_LINGUAS_IPK}"
local task="${INSTALL_TASK_IPK}"
@@ -139,7 +140,7 @@ package_install_internal_ipk() {
mkdir -p ${target_rootfs}${localstatedir}/lib/opkg/
- local ipkg_args="-f ${conffile} -o ${target_rootfs} --force_postinstall --prefer-arch-to-version"
+ local ipkg_args="${OPKG_ARGS}"
opkg-cl ${ipkg_args} update