aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes/package.bbclass
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-12-28 19:58:39 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2014-01-02 21:16:50 +0000
commit2b3080831042ffab26d70c3feee232fc31aa591a (patch)
treed5395ab07dfef62fee92a6ebcd3a84817f38bde1 /meta/classes/package.bbclass
parent4b022399815f32166c402d458a40afa6470fc776 (diff)
downloadopenembedded-core-contrib-2b3080831042ffab26d70c3feee232fc31aa591a.tar.gz
classes/package: set SUMMARY in do_split_packages()
do_split_packages() is commonly used to split out plugin/module packages dynamically within recipes. If it doesn't set SUMMARY for each of these packages then they get a generic SUMMARY from the recipe, which isn't particularly useful; so add a parameter to set this and default it from the current description parameter (it ought to have been the other way around, but the description parameter is what we currently have in use by all recipes that use this function.) Fixes [YOCTO #5406]. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta/classes/package.bbclass')
-rw-r--r--meta/classes/package.bbclass8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/classes/package.bbclass b/meta/classes/package.bbclass
index eb4cf44ef0..9b4f11aa30 100644
--- a/meta/classes/package.bbclass
+++ b/meta/classes/package.bbclass
@@ -72,7 +72,7 @@ def legitimize_package_name(s):
# Remaining package name validity fixes
return s.lower().replace('_', '-').replace('@', '+').replace(',', '+').replace('/', '-')
-def do_split_packages(d, root, file_regex, output_pattern, description, postinst=None, recursive=False, hook=None, extra_depends=None, aux_files_pattern=None, postrm=None, allow_dirs=False, prepend=False, match_path=False, aux_files_pattern_verbatim=None, allow_links=False):
+def do_split_packages(d, root, file_regex, output_pattern, description, postinst=None, recursive=False, hook=None, extra_depends=None, aux_files_pattern=None, postrm=None, allow_dirs=False, prepend=False, match_path=False, aux_files_pattern_verbatim=None, allow_links=False, summary=None):
"""
Used in .bb files to split up dynamically generated subpackages of a
given package, usually plugins or modules.
@@ -116,6 +116,8 @@ def do_split_packages(d, root, file_regex, output_pattern, description, postinst
package name. Can be a single string item or a list
of strings for multiple items. Must include %s.
allow_links -- True to allow symlinks to be matched - default False
+ summary -- Summary to set for each package. Must include %s;
+ defaults to description if not set.
"""
@@ -161,6 +163,9 @@ def do_split_packages(d, root, file_regex, output_pattern, description, postinst
if extra_depends == None:
extra_depends = d.getVar("PN", True)
+ if not summary:
+ summary = description
+
for o in sorted(objs):
import re, stat
if match_path:
@@ -206,6 +211,7 @@ def do_split_packages(d, root, file_regex, output_pattern, description, postinst
if extra_depends != '':
d.appendVar('RDEPENDS_' + pkg, ' ' + extra_depends)
d.setVar('DESCRIPTION_' + pkg, description % on)
+ d.setVar('SUMMARY_' + pkg, summary % on)
if postinst:
d.setVar('pkg_postinst_' + pkg, postinst)
if postrm: