aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes/insane.bbclass
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-04-22 11:28:08 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-04 00:52:20 +0100
commit7d4cb46017616867dea589be03973897a02991eb (patch)
treec591ca85b9593f0c91e164c22db7d1884cc093d6 /meta/classes/insane.bbclass
parent4b2a6fa780567c0876540bb89af78d5c778985cb (diff)
downloadopenembedded-core-contrib-7d4cb46017616867dea589be03973897a02991eb.tar.gz
insane.bbclass: Checking for NLS too when checking gettext dependency
Checking for gettext is not needed when --disable-nls is used Let user know what variant of gettext is missing e.g. gettext-native, gettext-nativesdk etc, reveals a bit more for user Check for virtual/gettext Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/classes/insane.bbclass')
-rw-r--r--meta/classes/insane.bbclass7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta/classes/insane.bbclass b/meta/classes/insane.bbclass
index a3ea0e5ef0..742be5e66a 100644
--- a/meta/classes/insane.bbclass
+++ b/meta/classes/insane.bbclass
@@ -578,7 +578,8 @@ Rerun configure task after fixing this. The path was '%s'""" % root)
if "configure.in" in files:
configs.append(os.path.join(root, "configure.in"))
- if "gettext" not in bb.data.getVar('P', d, True) and "gcc-runtime" not in bb.data.getVar('P', d, True):
+ cnf = bb.data.getVar('EXTRA_OECONF', d, True) or ""
+ if "gettext" not in bb.data.getVar('P', d, True) and "gcc-runtime" not in bb.data.getVar('P', d, True) and "--disable-nls" not in cnf:
if bb.data.inherits_class('native', d) or bb.data.inherits_class('cross', d) or bb.data.inherits_class('crosssdk', d) or bb.data.inherits_class('nativesdk', d):
gt = "gettext-native"
elif bb.data.inherits_class('cross-canadian', d):
@@ -590,8 +591,8 @@ Rerun configure task after fixing this. The path was '%s'""" % root)
for config in configs:
gnu = "grep \"^[[:space:]]*AM_GNU_GETTEXT\" %s >/dev/null" % config
if os.system(gnu) == 0:
- bb.fatal("""Gettext required but not in DEPENDS for file %s.
-Missing inherit gettext?""" % config)
+ bb.fatal("""%s required but not in DEPENDS for file %s.
+Missing inherit gettext?""" % (gt, config))
if not package_qa_check_license(workdir, d):
bb.fatal("Licensing Error: LIC_FILES_CHKSUM does not match, please fix")