aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes/image_types.bbclass
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2012-03-09 15:05:12 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-13 11:44:46 +0000
commit39f14c66d5df226689238810b759f502644deb5c (patch)
tree16aee39dbf473c6f8591043460fda754658294f7 /meta/classes/image_types.bbclass
parentb35c5e83d9f2e63917c2604046fb1a6d70a2a524 (diff)
downloadopenembedded-core-contrib-39f14c66d5df226689238810b759f502644deb5c.tar.gz
image_types: ensure .rootfs.ext3 is created before vmdk is created.
In the case of self-hosted-image.bb, IMAGE_FSTYPES = "vmdk", so the variables alltypes and subimages don't contain ext3, and .rootfs.ext3 won't be created, and finally the generated .hddimg and .vmdk don't have an actual rootfs -- the size of the .vmdk file is only about 9MB. [YOCTO #2067] Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
Diffstat (limited to 'meta/classes/image_types.bbclass')
-rw-r--r--meta/classes/image_types.bbclass6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/classes/image_types.bbclass b/meta/classes/image_types.bbclass
index 8b820182e2..e92f519078 100644
--- a/meta/classes/image_types.bbclass
+++ b/meta/classes/image_types.bbclass
@@ -26,13 +26,19 @@ def get_imagecmds(d):
# Live and VMDK images will be processed via inheriting
# bbclass and does not get processed here.
# vmdk depend on live images also depend on ext3 so ensure its present
+ # Note: we need to ensure ext3 is in alltypes, otherwise, subimages may
+ # not contain ext3 and the .rootfs.ext3 file won't be created.
if "vmdk" in types:
if "ext3" not in types:
types.append("ext3")
+ if "ext3" not in alltypes:
+ alltypes.append("ext3")
types.remove("vmdk")
if "live" in types:
if "ext3" not in types:
types.append("ext3")
+ if "ext3" not in alltypes:
+ alltypes.append("ext3")
types.remove("live")
if d.getVar('IMAGE_LINK_NAME', True):