aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes/image-live.bbclass
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-07-26 08:30:08 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-27 12:02:46 +0100
commitba8a726b7dbbca8e9ea9cc75964d366d094aa881 (patch)
tree17e3da2faf29153fb9c17ec12330e3fc7536b957 /meta/classes/image-live.bbclass
parent39130137e40fe62d7b9bf2c9226a082138217b37 (diff)
downloadopenembedded-core-contrib-ba8a726b7dbbca8e9ea9cc75964d366d094aa881.tar.gz
classes/image*: Revamp creation of live images
This creates a live image as an IMAGE_FSTYPES, thus removing the need to have additional -live.bb recipes. To create a live image one just needs to add live to the IMAGE_FSTYPES list (From OE-Core rev: b3ff63796cd6629975ff0a726ba18cc168e0a2b2) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/image-live.bbclass')
-rw-r--r--meta/classes/image-live.bbclass13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta/classes/image-live.bbclass b/meta/classes/image-live.bbclass
new file mode 100644
index 0000000000..c910488d64
--- /dev/null
+++ b/meta/classes/image-live.bbclass
@@ -0,0 +1,13 @@
+
+AUTO_SYSLINUXCFG = "1"
+INITRD = "${DEPLOY_DIR_IMAGE}/core-image-minimal-initramfs-${MACHINE}.cpio.gz"
+APPEND += "root=/dev/ram0 "
+TIMEOUT = "10"
+LABELS += "boot install"
+
+ROOTFS = "${DEPLOY_DIR_IMAGE}/${IMAGE_BASENAME}-${MACHINE}.ext3"
+
+do_bootimg[depends] += "core-image-minimal-initramfs:do_rootfs"
+do_bootimg[depends] += "${IMAGE_BASENAME}:do_rootfs"
+
+inherit bootimg