aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes/autotools.bbclass
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-12 14:24:35 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-14 12:02:01 +0100
commitacaefad1aa4b45813a004e0cd1d85bc013e435f4 (patch)
tree87439394226cd392fc053d347bfd7bcd0aeed9bd /meta/classes/autotools.bbclass
parent4d5c0f9838a3e96d1cfb4ca2fb27161d6cf0de8f (diff)
downloadopenembedded-core-contrib-acaefad1aa4b45813a004e0cd1d85bc013e435f4.tar.gz
autotools: Enhance gettext handling to better work with SCM versions of code
If we pull SCM based code using gettext, Makefile.in.in in the po directory can be missing. We therefore need to add this if its not already present. We could use gettextize if it wasn't so broken (for example requiring user input on stdin and installing way more files that we ever care about such as the m4 files). We also have a problem if a recipe sets a different AUX dir, for now fix this by allowing recipes to specify when this is being done using the AUTOTOOLS_AUXDIR variable. Ultimately we could likely figure this out automatically. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/autotools.bbclass')
-rw-r--r--meta/classes/autotools.bbclass8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index a4ce8519d5..041332208e 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -80,6 +80,8 @@ oe_runconf () {
fi
}
+AUTOTOOLS_AUXDIR ?= "${S}"
+
autotools_do_configure() {
case ${PN} in
autoconf*)
@@ -144,7 +146,11 @@ autotools_do_configure() {
echo "no" | glib-gettextize --force --copy
fi
else if grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
- cp ${STAGING_DATADIR}/gettext/config.rpath ${S}/
+ # We'd call gettextize here if it wasn't so broken...
+ cp ${STAGING_DATADIR}/gettext/config.rpath ${AUTOTOOLS_AUXDIR}/
+ if [ ! -e ${S}/po/Makefile.in.in ]; then
+ cp ${STAGING_DATADIR}/gettext/po/Makefile.in.in ${S}/po/
+ fi
fi
fi
fi