aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes/autotools.bbclass
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-04-28 21:49:31 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-04 00:49:33 +0100
commita1f09fce5caba389d0484b169f0cde85d64514fa (patch)
tree53464597ac08390625583a4ba47a9ae637405b04 /meta/classes/autotools.bbclass
parent123a7f49753aef4d5ccb5f5a5590c3c88775c6d0 (diff)
downloadopenembedded-core-contrib-a1f09fce5caba389d0484b169f0cde85d64514fa.tar.gz
logging: update existing oe* logging users to the bb* interface
The new bash logging class provides bbnote, bbwarn, bbfatal, and bbdebug replacements (as well as bbplain and bberror) for the oe* equivalents. Use the new bb* API in preparation to delete the oe* logging API. This patch was automatically generated by a sed script. The result has been visually inspected and used to build core-image-sato for qemux86. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta/classes/autotools.bbclass')
-rw-r--r--meta/classes/autotools.bbclass16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index cbd2e9666e..27f4a01f12 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -70,10 +70,10 @@ oe_runconf () {
if [ -x ${S}/configure ] ; then
cfgcmd="${S}/configure \
${CONFIGUREOPTS} ${EXTRA_OECONF} $@"
- oenote "Running $cfgcmd..."
- $cfgcmd || oefatal "oe_runconf failed"
+ bbnote "Running $cfgcmd..."
+ $cfgcmd || bbfatal "oe_runconf failed"
else
- oefatal "no configure script found"
+ bbfatal "no configure script found"
fi
}
@@ -132,7 +132,7 @@ autotools_do_configure() {
if grep "sed.*POTFILES" $CONFIGURE_AC >/dev/null; then
: do nothing -- we still have an old unmodified configure.ac
else
- oenote Executing glib-gettextize --force --copy
+ bbnote Executing glib-gettextize --force --copy
echo "no" | glib-gettextize --force --copy
fi
else if grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
@@ -142,11 +142,11 @@ autotools_do_configure() {
fi
mkdir -p m4
if grep "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then
- oenote Executing intltoolize --copy --force --automake
+ bbnote Executing intltoolize --copy --force --automake
intltoolize --copy --force --automake
fi
- oenote Executing autoreconf --verbose --install --force ${EXTRA_AUTORECONF} $acpaths
- autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths || oefatal "autoreconf execution failed."
+ bbnote Executing autoreconf --verbose --install --force ${EXTRA_AUTORECONF} $acpaths
+ autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths || bbfatal "autoreconf execution failed."
cd $olddir
fi
;;
@@ -154,7 +154,7 @@ autotools_do_configure() {
if [ -e ${S}/configure ]; then
oe_runconf
else
- oenote "nothing to configure"
+ bbnote "nothing to configure"
fi
}