aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes/autotools.bbclass
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-04-24 18:38:48 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-28 09:52:29 +0100
commit040d4dea9637a4723cbb2a74975130d3b86e569a (patch)
treeb07fab471f1b503f43ab453c9330b007461ce667 /meta/classes/autotools.bbclass
parent1efeeecc33862e4d8c618e1f118ba60258bc6c64 (diff)
downloadopenembedded-core-contrib-040d4dea9637a4723cbb2a74975130d3b86e569a.tar.gz
autotools.bbclass: Copy gettext files only if --disable-nls is not set
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/classes/autotools.bbclass')
-rw-r--r--meta/classes/autotools.bbclass19
1 files changed, 10 insertions, 9 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index 7ebf833603..cbd2e9666e 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -127,17 +127,18 @@ autotools_do_configure() {
else
CONFIGURE_AC=configure.ac
fi
- if grep "^[[:space:]]*AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
- if grep "sed.*POTFILES" $CONFIGURE_AC >/dev/null; then
- : do nothing -- we still have an old unmodified configure.ac
- else
- oenote Executing glib-gettextize --force --copy
- echo "no" | glib-gettextize --force --copy
+ if ! echo ${EXTRA_OECONF} | grep -q "\-\-disable-nls"; then
+ if grep "^[[:space:]]*AM_GLIB_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
+ if grep "sed.*POTFILES" $CONFIGURE_AC >/dev/null; then
+ : do nothing -- we still have an old unmodified configure.ac
+ else
+ oenote Executing glib-gettextize --force --copy
+ echo "no" | glib-gettextize --force --copy
+ fi
+ else if grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
+ cp ${STAGING_DATADIR}/gettext/config.rpath ${S}/
fi
- else if grep "^[[:space:]]*AM_GNU_GETTEXT" $CONFIGURE_AC >/dev/null; then
- cp ${STAGING_DATADIR}/gettext/config.rpath ${S}/
fi
-
fi
mkdir -p m4
if grep "^[[:space:]]*[AI][CT]_PROG_INTLTOOL" $CONFIGURE_AC >/dev/null; then