aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes/autotools.bbclass
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-05-31 16:27:17 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-30 08:45:11 +0100
commit5b1454304483a0bc725b32fd5458e5281c68112f (patch)
tree780108085556c0c97b3d389ae84bd91b10c37d24 /meta/classes/autotools.bbclass
parent56f6fc7d6de0a46046ea2abcc392b1da88e398ec (diff)
downloadopenembedded-core-contrib-5b1454304483a0bc725b32fd5458e5281c68112f.tar.gz
siteinfo: fix siteinfo_get_files to work with RSS
The siteconfig cache files in ACLOCALDIR setup by autotools.bbclass has been dropped after switching to RSS, so change the siteconfig search path back to SITECONFIG_SYSROOTCACHE and the parameter name changed from aclocalcache to sysrootcache. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/autotools.bbclass')
-rw-r--r--meta/classes/autotools.bbclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index ac04a07cb5..efa4098d63 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -141,7 +141,7 @@ ACLOCALEXTRAPATH_class-nativesdk = " -I ${STAGING_DATADIR_NATIVE}/aclocal/"
python autotools_aclocals () {
# Refresh variable with cache files
- d.setVar("CONFIG_SITE", siteinfo_get_files(d, aclocalcache=True))
+ d.setVar("CONFIG_SITE", siteinfo_get_files(d, sysrootcache=True))
}
CONFIGURE_FILES = "${S}/configure.in ${S}/configure.ac ${S}/config.h.in ${S}/acinclude.m4 Makefile.am"