aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes/autotools.bbclass
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2016-10-12 10:21:40 +1300
committerPaul Eggleton <paul.eggleton@linux.intel.com>2016-10-12 10:32:53 +1300
commitd9721dfc03d8cc0614dd6081cd4da109524eafca (patch)
tree4d92258d3cbaf1b4eeb3dd733b9239198b6cf234 /meta/classes/autotools.bbclass
parent806a910927f479207d47b06c20a0497e91203266 (diff)
downloadopenembedded-core-contrib-d9721dfc03d8cc0614dd6081cd4da109524eafca.tar.gz
classes/externalsrc: re-run do_configure when configure files changepaule/externalsrc-configure
If the user modifies files such as CMakeLists.txt in the case of cmake, we want do_configure to re-run so that those changes can take effect. In order to accomplish that, have a variable CONFIGURE_FILES which specifies a list of files that will be put into do_configure's checksum (either full paths, or just filenames which will be searched for in the entire source tree). CONFIGURE_FILES then just needs to be set appropriately depending on what do_configure is doing; for now I've set this for autotools and cmake which are the most common cases. Fixes [YOCTO #7617]. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta/classes/autotools.bbclass')
-rw-r--r--meta/classes/autotools.bbclass2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index ecbba9f603..c43ea9a7ef 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -259,6 +259,8 @@ python autotools_copy_aclocals () {
}
autotools_copy_aclocals[vardepsexclude] += "MACHINE SDK_ARCH BUILD_ARCH SDK_OS BB_TASKDEPDATA"
+CONFIGURE_FILES = "${S}/configure.in ${S}/configure.ac ${S}/config.h.in ${S}/acinclude.m4 Makefile.am"
+
autotools_do_configure() {
# WARNING: gross hack follows:
# An autotools built package generally needs these scripts, however only