aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes/autotools.bbclass
diff options
context:
space:
mode:
authorRoy.Li <rongqing.li@windriver.com>2013-06-26 09:58:35 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-28 09:14:07 +0100
commitb09bc24c94b26c3c89185d6821fda71fb7a1981b (patch)
treeb4de951104f7d8d759bc960ce1cbaa4a5352cd8b /meta/classes/autotools.bbclass
parentc62b1a33386439d0b4b51585fbc5b9198fd07068 (diff)
downloadopenembedded-core-contrib-b09bc24c94b26c3c89185d6821fda71fb7a1981b.tar.gz
autotools.bbclass: force copy Makefile.in.in to ${S}/po/
If a Makefile.in.in has existed under ${S}/po/ and is read-only, cp will fail. (From OE-Core rev: 6e1b17f19411ed897c53ae0ef41a2d2972a9c113) Signed-off-by: Roy.Li <rongqing.li@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/autotools.bbclass')
-rw-r--r--meta/classes/autotools.bbclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index 66c0f5d10a..4e4ef986bf 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -201,7 +201,7 @@ autotools_do_configure() {
# We'd call gettextize here if it wasn't so broken...
cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${AUTOTOOLS_AUXDIR}/
if [ -d ${S}/po/ ]; then
- cp ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/po/
+ cp -f ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/po/
if [ ! -e ${S}/po/remove-potcdate.sin ]; then
cp ${STAGING_DATADIR_NATIVE}/gettext/po/remove-potcdate.sin ${S}/po/
fi