aboutsummaryrefslogtreecommitdiffstats
path: root/meta/classes/autotools.bbclass
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-01-28 12:11:52 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-30 11:37:04 +0000
commit85b66791aa103a8b2fbdb517417d065aaa3368af (patch)
tree5d5d3efcad4727d0d9f387ff13ced052941a35cb /meta/classes/autotools.bbclass
parent2f1bcc19150f7299a99293091a2cebcc78c532ee (diff)
downloadopenembedded-core-contrib-85b66791aa103a8b2fbdb517417d065aaa3368af.tar.gz
autotools.bbclass: don't create subshell to delete configure scripts
(From OE-Core rev: 107ab45444bfaa2d287bb490f76b44fc827048b5) Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/autotools.bbclass')
-rw-r--r--meta/classes/autotools.bbclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/classes/autotools.bbclass b/meta/classes/autotools.bbclass
index 1400b44999..4601148fc3 100644
--- a/meta/classes/autotools.bbclass
+++ b/meta/classes/autotools.bbclass
@@ -226,9 +226,9 @@ autotools_do_configure() {
# for a package whose autotools are old, on an x86_64 machine, which the old
# config.sub does not support. Work around this by installing them manually
# regardless.
- ( for ac in `find ${S} -ignore_readdir_race -name configure.in -o -name configure.ac`; do
+ for ac in `find ${S} -ignore_readdir_race -name configure.in -o -name configure.ac`; do
rm -f `dirname $ac`/configure
- done )
+ done
if [ -e ${AUTOTOOLS_SCRIPT_PATH}/configure.in -o -e ${AUTOTOOLS_SCRIPT_PATH}/configure.ac ]; then
olddir=`pwd`
cd ${AUTOTOOLS_SCRIPT_PATH}