aboutsummaryrefslogtreecommitdiffstats
path: root/meta-yocto-bsp/recipes-core
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-05 13:25:58 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-05 17:32:15 +0100
commit2000698b17011bbde1c3e5bb01a7d6763316db5a (patch)
tree5080d6d280487d6a8341c18ae56706e5157a0823 /meta-yocto-bsp/recipes-core
parent9d6630d1749486e38066650e1de5849c9524adbc (diff)
downloadopenembedded-core-contrib-2000698b17011bbde1c3e5bb01a7d6763316db5a.tar.gz
meta-yocto: Split into distro and bsp components
Now we have settled on best practises and compliance criteria, bring meta-yocto into compliance by separating out the hardware support components into meta-yocto-bsp leaving policy configuration in meta-yocto. Also rename the meta-yocto scripts directory to OE-Core can be a clearly isolated component in poky. (From meta-yocto rev: eac90e27a032ea23d9a4f35c7eef8b1940c80e22) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto-bsp/recipes-core')
-rw-r--r--meta-yocto-bsp/recipes-core/netbase/netbase-5.0/beagleboard/interfaces27
-rw-r--r--meta-yocto-bsp/recipes-core/netbase/netbase_5.0.bbappend1
-rw-r--r--meta-yocto-bsp/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend2
-rw-r--r--meta-yocto-bsp/recipes-core/uclibc/uclibc/atom-pc/uClibc.machine69
-rw-r--r--meta-yocto-bsp/recipes-core/uclibc/uclibc_git.bbappend1
5 files changed, 100 insertions, 0 deletions
diff --git a/meta-yocto-bsp/recipes-core/netbase/netbase-5.0/beagleboard/interfaces b/meta-yocto-bsp/recipes-core/netbase/netbase-5.0/beagleboard/interfaces
new file mode 100644
index 0000000000..b6935c11af
--- /dev/null
+++ b/meta-yocto-bsp/recipes-core/netbase/netbase-5.0/beagleboard/interfaces
@@ -0,0 +1,27 @@
+# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
+
+# The loopback interface
+auto lo
+iface lo inet loopback
+
+# Wireless interfaces
+iface wlan0 inet dhcp
+ wireless_mode managed
+ wireless_essid any
+ wpa-driver wext
+ wpa-conf /etc/wpa_supplicant.conf
+
+iface atml0 inet dhcp
+
+# Wired or wireless interfaces
+auto eth0
+iface eth0 inet dhcp
+iface eth1 inet dhcp
+
+# Ethernet/RNDIS gadget (g_ether) or LAN9514 on BeagleBoard xM
+auto usb0
+iface usb0 inet dhcp
+
+# Bluetooth networking
+iface bnep0 inet dhcp
+
diff --git a/meta-yocto-bsp/recipes-core/netbase/netbase_5.0.bbappend b/meta-yocto-bsp/recipes-core/netbase/netbase_5.0.bbappend
new file mode 100644
index 0000000000..56223033bd
--- /dev/null
+++ b/meta-yocto-bsp/recipes-core/netbase/netbase_5.0.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-${PV}:"
diff --git a/meta-yocto-bsp/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend b/meta-yocto-bsp/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend
new file mode 100644
index 0000000000..352c1f9f22
--- /dev/null
+++ b/meta-yocto-bsp/recipes-core/packagegroups/packagegroup-core-tools-profile.bbappend
@@ -0,0 +1,2 @@
+RDEPENDS_${PN}_append_atom-pc = " lttng-ust systemtap"
+
diff --git a/meta-yocto-bsp/recipes-core/uclibc/uclibc/atom-pc/uClibc.machine b/meta-yocto-bsp/recipes-core/uclibc/uclibc/atom-pc/uClibc.machine
new file mode 100644
index 0000000000..5df15f94cb
--- /dev/null
+++ b/meta-yocto-bsp/recipes-core/uclibc/uclibc/atom-pc/uClibc.machine
@@ -0,0 +1,69 @@
+#
+# Automatically generated make config: don't edit
+# Fri Nov 23 15:49:33 2007
+#
+# TARGET_alpha is not set
+# TARGET_arm is not set
+# TARGET_bfin is not set
+# TARGET_cris is not set
+# TARGET_e1 is not set
+# TARGET_frv is not set
+# TARGET_h8300 is not set
+# TARGET_hppa is not set
+TARGET_i386=y
+# TARGET_i960 is not set
+# TARGET_ia64 is not set
+# TARGET_m68k is not set
+# TARGET_microblaze is not set
+# TARGET_mips is not set
+# TARGET_nios is not set
+# TARGET_nios2 is not set
+# TARGET_powerpc is not set
+# TARGET_sh is not set
+# TARGET_sh64 is not set
+# TARGET_sparc is not set
+# TARGET_v850 is not set
+# TARGET_vax is not set
+# TARGET_x86_64 is not set
+
+#
+# Target Architecture Features and Options
+#
+TARGET_ARCH="i386"
+FORCE_OPTIONS_FOR_ARCH=y
+CONFIG_GENERIC_386=y
+# CONFIG_386 is not set
+# CONFIG_486 is not set
+# CONFIG_586 is not set
+# CONFIG_586MMX is not set
+# CONFIG_686 is not set
+# CONFIG_PENTIUMII is not set
+# CONFIG_PENTIUMIII is not set
+# CONFIG_PENTIUM4 is not set
+# CONFIG_K6 is not set
+# CONFIG_K7 is not set
+# CONFIG_ELAN is not set
+# CONFIG_CRUSOE is not set
+# CONFIG_WINCHIPC6 is not set
+# CONFIG_WINCHIP2 is not set
+# CONFIG_CYRIXIII is not set
+# CONFIG_NEHEMIAH is not set
+TARGET_SUBARCH=""
+
+#
+# Using ELF file format
+#
+ARCH_LITTLE_ENDIAN=y
+
+#
+# Using Little Endian
+#
+ARCH_HAS_MMU=y
+ARCH_USE_MMU=y
+UCLIBC_HAS_FLOATS=y
+UCLIBC_HAS_FPU=y
+DO_C99_MATH=y
+KERNEL_HEADERS="/usr/include"
+HAVE_DOT_CONFIG=y
+
+UCLIBC_HAS_FENV=y
diff --git a/meta-yocto-bsp/recipes-core/uclibc/uclibc_git.bbappend b/meta-yocto-bsp/recipes-core/uclibc/uclibc_git.bbappend
new file mode 100644
index 0000000000..72d991c7e5
--- /dev/null
+++ b/meta-yocto-bsp/recipes-core/uclibc/uclibc_git.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"