summaryrefslogtreecommitdiffstats
path: root/meta-skeleton
diff options
context:
space:
mode:
authorScott Garman <scott.a.garman@intel.com>2011-11-08 18:42:02 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-10 11:35:30 +0000
commit70aaac37968bf2b35d6a536c3f3f69fe3620255c (patch)
tree10bc66683147bdc1015e04350119037174f1cf8c /meta-skeleton
parent2f057dd905ccb497890ce73ac4e4c256edcf0351 (diff)
downloadopenembedded-core-contrib-70aaac37968bf2b35d6a536c3f3f69fe3620255c.tar.gz
useradd-example.bb: update example documentation comments
Clarify that only packages listed in USERADD_PACKAGES will include the user/group creation code. Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Diffstat (limited to 'meta-skeleton')
-rw-r--r--meta-skeleton/recipes-skeleton/useradd/useradd-example.bb9
1 files changed, 4 insertions, 5 deletions
diff --git a/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb b/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb
index 02d56f6abc..b10c1d0c37 100644
--- a/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb
+++ b/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb
@@ -17,13 +17,12 @@ PACKAGES =+ "${PN}-user3"
inherit useradd
-# Specify which package(s) should include the user/group code.
-# Make sure that any packages which install files owned by custom
-# users/groups are included here. The code which adds users and
-# groups is idempotent.
+# You must set USERADD_PACKAGES when you inherit useradd. This
+# lists which output packages will include the user/group
+# creation code.
USERADD_PACKAGES = "${PN} ${PN}-user3"
-# You *must* set USERADD_PARAM and/or GROUPADD_PARAM when
+# You must also set USERADD_PARAM and/or GROUPADD_PARAM when
# you inherit useradd.
# USERADD_PARAM specifies command line options to pass to the