aboutsummaryrefslogtreecommitdiffstats
path: root/meta-skeleton
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2015-08-05 09:42:07 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-24 23:45:21 +0100
commite6cf787871518119205c7d764f5478fd853e2576 (patch)
tree98df376ba921fc6ebd1d6bbc1a3c6a88675ef90e /meta-skeleton
parent91b323526427f67a8982c7b090e505aaf810d4e7 (diff)
downloadopenembedded-core-contrib-e6cf787871518119205c7d764f5478fd853e2576.tar.gz
service: tweak example recipe
* Drop PR = "r0" * Reorder lines so that packaging definitions are at the end Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta-skeleton')
-rw-r--r--meta-skeleton/recipes-skeleton/service/service_0.1.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/meta-skeleton/recipes-skeleton/service/service_0.1.bb b/meta-skeleton/recipes-skeleton/service/service_0.1.bb
index a3ad6ccb2f..c5cd7a97bc 100644
--- a/meta-skeleton/recipes-skeleton/service/service_0.1.bb
+++ b/meta-skeleton/recipes-skeleton/service/service_0.1.bb
@@ -2,16 +2,12 @@ SUMMARY = "The canonical example of init scripts"
SECTION = "base"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYRIGHT;md5=349c872e0066155e1818b786938876a4"
-RDEPENDS_${PN} = "initscripts"
-PR = "r0"
SRC_URI = "file://skeleton \
file://skeleton_test.c \
file://COPYRIGHT \
"
-CONFFILES_${PN} += "${sysconfdir}/init.d/skeleton"
-
do_compile () {
${CC} ${WORKDIR}/skeleton_test.c -o ${WORKDIR}/skeleton-test
}
@@ -30,3 +26,6 @@ do_install () {
install -m 0755 ${WORKDIR}/skeleton-test ${D}${sbindir}/
}
+RDEPENDS_${PN} = "initscripts"
+
+CONFFILES_${PN} += "${sysconfdir}/init.d/skeleton"