aboutsummaryrefslogtreecommitdiffstats
path: root/meta-skeleton/recipes-kernel/hello-mod/files/Makefile
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2012-04-09 15:19:00 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-10 13:16:00 +0100
commitbde1744018afd4616e114b20ffdc21b9abddcedc (patch)
tree5eb8a7c529db77905c98ba78d0ac51604e21a110 /meta-skeleton/recipes-kernel/hello-mod/files/Makefile
parentd037060e2fec073ccfb33c83d426c9775b331457 (diff)
downloadopenembedded-core-contrib-bde1744018afd4616e114b20ffdc21b9abddcedc.tar.gz
hello-mod: Move hello-mod from meta to meta-skeleton
Fixes [YOCTO #1501] hello-mod is an example kernel module, and does not provide any real functionality. As such, it would be better placed under meta-skeleton than meta. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Diffstat (limited to 'meta-skeleton/recipes-kernel/hello-mod/files/Makefile')
-rw-r--r--meta-skeleton/recipes-kernel/hello-mod/files/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-skeleton/recipes-kernel/hello-mod/files/Makefile b/meta-skeleton/recipes-kernel/hello-mod/files/Makefile
new file mode 100644
index 0000000000..4ded35fbc3
--- /dev/null
+++ b/meta-skeleton/recipes-kernel/hello-mod/files/Makefile
@@ -0,0 +1,14 @@
+obj-m := hello.o
+
+SRC := $(shell pwd)
+
+all:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC)
+
+modules_install:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules_install
+
+clean:
+ rm -f *.o *~ core .depend .*.cmd *.ko *.mod.c
+ rm -f Module.markers Module.symvers modules.order
+ rm -rf .tmp_versions Modules.symvers