aboutsummaryrefslogtreecommitdiffstats
path: root/meta-selftest
diff options
context:
space:
mode:
authorEd Bartosh <ed.bartosh@linux.intel.com>2016-02-13 11:02:19 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-15 16:28:44 +0000
commit9b6dc9b07e8eb53b4783abf2b9189081ae6bcf5d (patch)
treeed26e31ba94ce8bb5da19dafcac986a549924ca6 /meta-selftest
parentab7cb65ab574ab1bb99057b7cbe442fe5a14a9f8 (diff)
downloadopenembedded-core-contrib-9b6dc9b07e8eb53b4783abf2b9189081ae6bcf5d.tar.gz
wic-image-minimal: use uuid for root partition
Used --uuid option to generate PARTUUID for root partion and gpt partition type. As this image is used in runtime testing under qemu it makes sense to ensure that this way of specifying root partition works. Added dependency to gptfdisk-native to wic-image-minimal recipe to be able to create gpt partition table. (From OE-Core rev: ba82867bfda54e86e1de5dc4a6ad7246254cf5c3) (From OE-Core rev: 767d814b2e125e20839f204e17512ebe2aec8b95) Signed-off-by: Ed Bartosh <ed.bartosh@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest')
-rw-r--r--meta-selftest/recipes-test/images/wic-image-minimal.bb2
-rw-r--r--meta-selftest/recipes-test/images/wic-image-minimal.wks4
2 files changed, 3 insertions, 3 deletions
diff --git a/meta-selftest/recipes-test/images/wic-image-minimal.bb b/meta-selftest/recipes-test/images/wic-image-minimal.bb
index ced22c822a..9c50ddbbf5 100644
--- a/meta-selftest/recipes-test/images/wic-image-minimal.bb
+++ b/meta-selftest/recipes-test/images/wic-image-minimal.bb
@@ -7,7 +7,7 @@ IMAGE_INSTALL = "packagegroup-core-boot ${ROOTFS_PKGMANAGE_BOOTSTRAP}"
IMAGE_FSTYPES = "wic"
RM_OLD_IMAGE = "1"
-DEPENDS = "syslinux syslinux-native parted-native dosfstools-native mtools-native"
+DEPENDS = "syslinux syslinux-native parted-native dosfstools-native mtools-native gptfdisk-native"
# core-image-minimal is referenced in .wks, so we need its rootfs
# to be ready before our rootfs
diff --git a/meta-selftest/recipes-test/images/wic-image-minimal.wks b/meta-selftest/recipes-test/images/wic-image-minimal.wks
index 191244bade..d55075d503 100644
--- a/meta-selftest/recipes-test/images/wic-image-minimal.wks
+++ b/meta-selftest/recipes-test/images/wic-image-minimal.wks
@@ -3,8 +3,8 @@
# created from core-image-minimal and wic-image-minimal image recipes.
part /boot --source bootimg-pcbios --ondisk vda --label boot --active --align 1024
-part / --source rootfs --ondisk vda --fstype=ext4 --label platform --align 1024
+part / --source rootfs --ondisk vda --fstype=ext4 --label platform --align 1024 --use-uuid
part /mnt --source rootfs --rootfs-dir=core-image-minimal --ondisk vda --fstype=ext4 --label core --align 1024
part backup --source rootfs --rootfs-dir=wic-image-minimal --ondisk vda --fstype=ext4 --label backup --align 1024
-bootloader --timeout=0 --append="rootwait console=tty0 root=/dev/vda2"
+bootloader --ptable gpt --timeout=0 --append="rootwait console=tty0"