aboutsummaryrefslogtreecommitdiffstats
path: root/meta-selftest/recipes-test
diff options
context:
space:
mode:
authorEd Bartosh <ed.bartosh@linux.intel.com>2015-08-31 00:14:25 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-30 23:26:14 +0100
commitf7069cbfb8f1e8273584221999d0739f1ae173c4 (patch)
tree9e3e7fb8431deabf3b94cf17e13ee5016b599011 /meta-selftest/recipes-test
parenteaa5ecd2e7ff30192e51793d1419c0198638936d (diff)
downloadopenembedded-core-contrib-f7069cbfb8f1e8273584221999d0739f1ae173c4.tar.gz
wic-image-minimal: add wic image recipe and .wks
Added example of recipe and .wks file to create partitioned image. This image is using quite complex partitioning scheme. It uses its own rootfs to populate two partitions in two different ways. It also uses core-image-minimal rootfs to populate another partition. This is how wic reports about artifacts used to create this image: ROOTFS_DIR: tmp/work/qemux86_64-poky-linux/wic-image-minimal/1.0-r0/rootfs ROOTFS_DIR["/core"]: tmp/work/qemux86_64-poky-linux/core-image-minimal/1.0-r0/rootfs ROOTFS_DIR["/backup"]: tmp/work/qemux86_64-poky-linux/wic-image-minimal/1.0-r0/rootfs BOOTIMG_DIR: tmp/sysroots/qemux86-64/usr/share KERNEL_DIR: tmp/deploy/images/qemux86-64 NATIVE_SYSROOT: tmp/sysroots/x86_64-linux Signed-off-by: Ed Bartosh <ed.bartosh@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest/recipes-test')
-rw-r--r--meta-selftest/recipes-test/images/wic-image-minimal.bb14
-rw-r--r--meta-selftest/recipes-test/images/wic-image-minimal.wks10
2 files changed, 24 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/images/wic-image-minimal.bb b/meta-selftest/recipes-test/images/wic-image-minimal.bb
new file mode 100644
index 0000000000..073c569fe2
--- /dev/null
+++ b/meta-selftest/recipes-test/images/wic-image-minimal.bb
@@ -0,0 +1,14 @@
+SUMMARY = "An example of partitioned image."
+
+IMAGE_INSTALL = "packagegroup-core-boot ${ROOTFS_PKGMANAGE_BOOTSTRAP}"
+
+IMAGE_FSTYPES = "wic.bz2"
+RM_OLD_IMAGE = "1"
+
+# core-image-minimal is referenced in .wks, so we need its rootfs
+# to be ready before our rootfs
+do_rootfs[depends] += "core-image-minimal:do_rootfs"
+
+IMAGE_ROOTFS_EXTRA_SPACE = "2000"
+
+inherit image
diff --git a/meta-selftest/recipes-test/images/wic-image-minimal.wks b/meta-selftest/recipes-test/images/wic-image-minimal.wks
new file mode 100644
index 0000000000..29cd8f2c8a
--- /dev/null
+++ b/meta-selftest/recipes-test/images/wic-image-minimal.wks
@@ -0,0 +1,10 @@
+# short-description: Example of partitioned image with complex layout
+# long-description: This image contains boot partition and 3 rootfs partitions
+# created from core-image-minimal and wic-image-minimal image recipes.
+
+part /boot --source bootimg-pcbios --ondisk sda --label boot --active --align 1024
+part / --source rootfs --ondisk sda --fstype=ext2 --label platform --align 1024
+part /core --source rootfs --rootfs-dir=core-image-minimal --ondisk sda --fstype=ext2 --label core --align 1024
+part /backup --source rootfs --rootfs-dir=wic-image-minimal --ondisk sda --fstype=ext2 --label backup --align 1024
+
+bootloader --timeout=0 --append="rootwait console=tty0"