aboutsummaryrefslogtreecommitdiffstats
path: root/meta-selftest/recipes-test/selftest-ed/selftest-ed_1.14.1.bb
diff options
context:
space:
mode:
authorJoshua Lock <joshua.g.lock@intel.com>2017-03-08 16:46:03 +0000
committerJoshua Lock <joshua.g.lock@intel.com>2017-03-08 17:01:34 +0000
commit17654b4d7d09bb1bd4f7d3471c6bfef7eeef2e59 (patch)
tree2599f8b0dc24a8c4ec4ea7f3380bf878b382e53a /meta-selftest/recipes-test/selftest-ed/selftest-ed_1.14.1.bb
parent1ec75104e2b1c51911905e8318f36b291a7dccef (diff)
downloadopenembedded-core-contrib-17654b4d7d09bb1bd4f7d3471c6bfef7eeef2e59.tar.gz
meta-selftest: add selftest-ed recipes
The oe-selftest oescripts.TestScripts.test_cleanup_workdir was using gzip and the GPLv2 variant to test cleanup of the workdir. This broke with the removal of GPLv2 recipes from OE-Core. Instead of relying on recipes in OE-Core remaining static we should ensure that meta-selftest provides recipes required for the tests to pass. To that end we take a copy of the current GPLv2 and GPLv3 variants of ed and include them in meta-selftest as new recipes. We chose ed over gzip as gzip has dependencies which would require additional GPLv2 recipes to be included in meta-selftest. Signed-off-by: Joshua Lock <joshua.g.lock@intel.com>
Diffstat (limited to 'meta-selftest/recipes-test/selftest-ed/selftest-ed_1.14.1.bb')
-rw-r--r--meta-selftest/recipes-test/selftest-ed/selftest-ed_1.14.1.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/selftest-ed/selftest-ed_1.14.1.bb b/meta-selftest/recipes-test/selftest-ed/selftest-ed_1.14.1.bb
new file mode 100644
index 0000000000..62931c404b
--- /dev/null
+++ b/meta-selftest/recipes-test/selftest-ed/selftest-ed_1.14.1.bb
@@ -0,0 +1,35 @@
+SUMMARY = "Line-oriented text editor -- selftest variant"
+HOMEPAGE = "http://www.gnu.org/software/ed/"
+
+LICENSE = "GPLv3+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0c7051aef9219dc7237f206c5c4179a7 \
+ file://ed.h;endline=20;md5=4e36b7a40e137f42aee718165590d125 \
+ file://main.c;endline=17;md5=c5b8f78f115df187af76868a2aead16a"
+
+SECTION = "base"
+
+# LSB states that ed should be in /bin/
+bindir = "${base_bindir}"
+
+SRC_URI = "${GNU_MIRROR}/ed/ed-${PV}.tar.lz"
+
+SRC_URI[md5sum] = "7f4a54fa7f366479f03654b8af645fd0"
+SRC_URI[sha256sum] = "ffb97eb8f2a2b5a71a9b97e3872adce953aa1b8958e04c5b7bf11d556f32552a"
+
+S = "${WORKDIR}/ed-${PV}"
+
+EXTRA_OEMAKE = "-e MAKEFLAGS="
+
+inherit texinfo
+
+do_configure() {
+ ${S}/configure
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+ # Info dir listing isn't interesting at this point so remove it if it exists.
+ if [ -e "${D}${infodir}/dir" ]; then
+ rm -f ${D}${infodir}/dir
+ fi
+}