aboutsummaryrefslogtreecommitdiffstats
path: root/meta-selftest/recipes-test/selftest-ed/selftest-ed_0.5.bb
diff options
context:
space:
mode:
authorJoshua Lock <joshua.g.lock@intel.com>2017-03-08 16:46:03 +0000
committerJoshua Lock <joshua.g.lock@intel.com>2017-03-08 17:01:34 +0000
commit17654b4d7d09bb1bd4f7d3471c6bfef7eeef2e59 (patch)
tree2599f8b0dc24a8c4ec4ea7f3380bf878b382e53a /meta-selftest/recipes-test/selftest-ed/selftest-ed_0.5.bb
parent1ec75104e2b1c51911905e8318f36b291a7dccef (diff)
downloadopenembedded-core-contrib-17654b4d7d09bb1bd4f7d3471c6bfef7eeef2e59.tar.gz
meta-selftest: add selftest-ed recipes
The oe-selftest oescripts.TestScripts.test_cleanup_workdir was using gzip and the GPLv2 variant to test cleanup of the workdir. This broke with the removal of GPLv2 recipes from OE-Core. Instead of relying on recipes in OE-Core remaining static we should ensure that meta-selftest provides recipes required for the tests to pass. To that end we take a copy of the current GPLv2 and GPLv3 variants of ed and include them in meta-selftest as new recipes. We chose ed over gzip as gzip has dependencies which would require additional GPLv2 recipes to be included in meta-selftest. Signed-off-by: Joshua Lock <joshua.g.lock@intel.com>
Diffstat (limited to 'meta-selftest/recipes-test/selftest-ed/selftest-ed_0.5.bb')
-rw-r--r--meta-selftest/recipes-test/selftest-ed/selftest-ed_0.5.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/selftest-ed/selftest-ed_0.5.bb b/meta-selftest/recipes-test/selftest-ed/selftest-ed_0.5.bb
new file mode 100644
index 0000000000..8e0d1cdd8e
--- /dev/null
+++ b/meta-selftest/recipes-test/selftest-ed/selftest-ed_0.5.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Line-oriented text editor -- selftest GPLv2 version"
+HOMEPAGE = "http://www.gnu.org/software/ed/"
+SECTION = "base"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=6ddd5335ef96fb858a138230af773710 \
+ file://main.c;beginline=1;endline=17;md5=36d4b85e5ae9028e918d1cc775c2475e"
+
+PR = "r2"
+SRC_URI = "${SAVANNAH_GNU_MIRROR}/ed/ed-${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "4ee21e9dcc9b5b6012c23038734e1632"
+SRC_URI[sha256sum] = "edef2bbde0fbf0d88232782a0eded323f483a0519d6fde9a3b1809056fd35f3e"
+
+inherit autotools texinfo
+
+S = "${WORKDIR}/ed-${PV}"
+
+EXTRA_OECONF = "'CC=${CC}' 'CXX=${CXX}' 'CFLAGS=${CFLAGS}' 'CXXFLAGS=${CXXFLAGS}' 'CPPFLAGS=${CPPFLAGS}' 'LDFLAGS=${LDFLAGS}'"
+
+CONFIGUREOPTS_remove = "--disable-dependency-tracking"
+CONFIGUREOPTS_remove = "--disable-silent-rules"
+EXTRA_OECONF_remove = "--disable-static"