aboutsummaryrefslogtreecommitdiffstats
path: root/meta-selftest/recipes-test/images/oe-selftest-image.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2015-03-13 18:27:06 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-03-20 11:03:13 +0000
commit9dc16a8a87bef5dc408aefb256c01e2a4fe3563c (patch)
treeff7f7967e59f61d3e067c3526959d0b4fcd9a5fd /meta-selftest/recipes-test/images/oe-selftest-image.bb
parent48b58466bba084fd3439706d47e0cfbb7e951ee4 (diff)
downloadopenembedded-core-contrib-9dc16a8a87bef5dc408aefb256c01e2a4fe3563c.tar.gz
oe-selftest: add a test for devtool deploy-target
Whilst this test would seemingly be better placed as a runtime test, unfortunately the runtime tests run under bitbake and you can't run devtool within bitbake (since devtool needs to run bitbake itself). Additionally we are testing build-time functionality as well, so really this has to be done as an oe-selftest test. This test does have a few perhaps unusual requirements in order to run: * pexpect is installed * MACHINE is set to one of the qemu machines * runqemu tap devices have been set up Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta-selftest/recipes-test/images/oe-selftest-image.bb')
-rw-r--r--meta-selftest/recipes-test/images/oe-selftest-image.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/images/oe-selftest-image.bb b/meta-selftest/recipes-test/images/oe-selftest-image.bb
new file mode 100644
index 0000000000..f17094c5d0
--- /dev/null
+++ b/meta-selftest/recipes-test/images/oe-selftest-image.bb
@@ -0,0 +1,9 @@
+SUMMARY = "An image used during oe-selftest tests"
+
+IMAGE_INSTALL = "packagegroup-core-boot ${ROOTFS_PKGMANAGE_BOOTSTRAP} dropbear"
+IMAGE_FEATURES = "debug-tweaks"
+
+IMAGE_LINGUAS = " "
+
+inherit core-image
+