summaryrefslogtreecommitdiffstats
path: root/meta-extras
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-06-11 12:12:32 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-06-11 12:12:32 +0000
commitead8b803b3c7f2fa03caf5af0e3223151a812b74 (patch)
treed9f6d99687dfe7b2438b856e60e3cc7659d752f9 /meta-extras
parented327197a7e68e72f8d9be9a3e970962c8eea35b (diff)
downloadopenembedded-core-contrib-ead8b803b3c7f2fa03caf5af0e3223151a812b74.tar.gz
zope: added 3.3.1
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1913 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras')
-rw-r--r--meta-extras/packages/zope/zope_3.3.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-extras/packages/zope/zope_3.3.1.bb b/meta-extras/packages/zope/zope_3.3.1.bb
new file mode 100644
index 0000000000..4c4664904c
--- /dev/null
+++ b/meta-extras/packages/zope/zope_3.3.1.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "A full fledged pluggable content management system with integrated web server and much more."
+SECTION = "console/network"
+PRIORITY = "optional"
+DEPENDS = "python"
+RDEPENDS = "python-core python-shell"
+LICENSE = "ZPL"
+PR = "r1"
+
+SRC_URI = "http://www.zope.org/Products/Zope3/${PV}/Zope-${PV}.tgz"
+
+S = "${WORKDIR}/Zope-${PV}"
+
+do_configure() {
+ ./configure --with-python=${STAGING_BINDIR_NATIVE}/python --prefix=${prefix} --force
+}
+
+do_compile() {
+ oe_runmake HOST_SYS=${HOST_SYS} BUILD_SYS=${BUILD_SYS}
+}
+
+do_install() {
+ oe_runmake install prefix=${D}${prefix} HOST_SYS=${HOST_SYS} BUILD_SYS=${BUILD_SYS}
+}
+
+PACKAGES =+ "python-zopeinterface"
+
+FILES_${PN} = "${prefix}"
+FILES_${PN}_doc = "${prefix}/doc"
+FILES_python-zopeinterface = "${libdir}/python/zope/interface/*.* ${libdir}/python/zope/interface/common"