aboutsummaryrefslogtreecommitdiffstats
path: root/meta-extras
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-11-05 17:32:08 +0000
committerRoss Burton <ross@openedhand.com>2007-11-05 17:32:08 +0000
commit2188cf09e11398447a6e59ee8a2819877f90b45c (patch)
tree53ac6e0fbb0c318feef6d67b45d54f5208154ed6 /meta-extras
parent378c8dbafe89e22ad8ce3463968c366c4d745d4d (diff)
downloadopenembedded-core-contrib-2188cf09e11398447a6e59ee8a2819877f90b45c.tar.gz
ubootchart: add a launcher to stop the profiling, alternatives to optionally replace /sbin/init, and cleanly pretend to be /sbin/init
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3071 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras')
-rw-r--r--meta-extras/packages/ubootchart/files/pass-args.patch21
-rw-r--r--meta-extras/packages/ubootchart/files/ubootchart-stop3
-rw-r--r--meta-extras/packages/ubootchart/files/ubootchart.desktop6
-rw-r--r--meta-extras/packages/ubootchart/ubootchart_svn.bb21
4 files changed, 48 insertions, 3 deletions
diff --git a/meta-extras/packages/ubootchart/files/pass-args.patch b/meta-extras/packages/ubootchart/files/pass-args.patch
new file mode 100644
index 0000000000..9ad4282f21
--- /dev/null
+++ b/meta-extras/packages/ubootchart/files/pass-args.patch
@@ -0,0 +1,21 @@
+Index: ubootchartd
+===================================================================
+--- ubootchartd (revision 9)
++++ ubootchartd (working copy)
+@@ -7,9 +7,11 @@
+ # can read.
+ . /etc/ubootchart/ubootchart.conf
+
+-####################################################
+-# Now start capturing the stats:
+-####################################################
+-/sbin/ubootchartd_bin &
+-exec $init_prog
++if [ $$ -eq 1 ]; then
++ ####################################################
++ # Now start capturing the stats:
++ ####################################################
++ /sbin/ubootchartd_bin &
++fi
+
++exec $init_prog "$@"
diff --git a/meta-extras/packages/ubootchart/files/ubootchart-stop b/meta-extras/packages/ubootchart/files/ubootchart-stop
new file mode 100644
index 0000000000..3444069c9a
--- /dev/null
+++ b/meta-extras/packages/ubootchart/files/ubootchart-stop
@@ -0,0 +1,3 @@
+#! /bin/sh
+
+kill -USR1 $(pidof ubootchartd_bin)
diff --git a/meta-extras/packages/ubootchart/files/ubootchart.desktop b/meta-extras/packages/ubootchart/files/ubootchart.desktop
new file mode 100644
index 0000000000..5552b3bc6f
--- /dev/null
+++ b/meta-extras/packages/ubootchart/files/ubootchart.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Encoding=UTF-8
+Exec=/sbin/ubootchart-stop
+Name=Stop Bootchart
+Type=Application
+Categories=Programming;
diff --git a/meta-extras/packages/ubootchart/ubootchart_svn.bb b/meta-extras/packages/ubootchart/ubootchart_svn.bb
index 95e09c98a8..7ab485c58c 100644
--- a/meta-extras/packages/ubootchart/ubootchart_svn.bb
+++ b/meta-extras/packages/ubootchart/ubootchart_svn.bb
@@ -2,22 +2,37 @@ DESCRIPTION = "A boot profiling tool"
HOMEPAGE = "http://code.google.com/p/ubootchart/"
LICENSE = "GPLv3"
PV = "0.0+r${SRCREV}"
+PR = "r2"
+
+RRECOMMENDS = "acct"
SRC_URI = "svn://ubootchart.googlecode.com/svn/;proto=http;module=trunk \
- file://sysvinit.patch;patch=1;pnum=0"
+ file://sysvinit.patch;patch=1;pnum=0 \
+ file://pass-args.patch;patch=1;pnum=0 \
+ file://ubootchart-stop \
+ file://ubootchart.desktop"
S = "${WORKDIR}/trunk"
+inherit update-alternatives
+
+ALTERNATIVE_NAME = "init"
+ALTERNATIVE_LINK = "${base_sbindir}/init"
+ALTERNATIVE_PATH = "${base_sbindir}/ubootchartd"
+ALTERNATIVE_PRIORITY = "20"
+
do_compile() {
${CC} ${CFLAGS} ${LDFLAGS} ${LIBS} ${INCLUDES} ${S}/ubootchartd_bin.c -o ubootchartd_bin
}
do_install() {
- install -m 0755 -d ${D}/sbin ${D}/etc/ubootchart
+ install -m 0755 -d ${D}/sbin ${D}/etc/ubootchart ${D}/usr/share/applications
install -m 0755 ${S}/ubootchartd_bin ${D}/sbin
install -m 0755 ${S}/ubootchartd ${D}/sbin
install -m 0644 ${S}/ubootchart.conf ${D}/etc/ubootchart
install -m 0755 ${S}/start.sh ${D}/etc/ubootchart
install -m 0755 ${S}/finish.sh ${D}/etc/ubootchart
+
+ install -m 0755 ${WORKDIR}/ubootchart-stop ${D}/sbin
+ install -m 0644 ${WORKDIR}/ubootchart.desktop ${D}/usr/share/applications
}
-