summaryrefslogtreecommitdiffstats
path: root/meta-extras/packages/python/python-2.4.4/fix-tkinter-detection.patch
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-03-01 16:16:56 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-03-01 16:16:56 +0000
commit1b7b0c28d8d6a99e7a52feeb0bfce7b5bd305691 (patch)
tree3d5b85d1e94acab14e7d8a9409a2265610ff5444 /meta-extras/packages/python/python-2.4.4/fix-tkinter-detection.patch
parenteff0c4b55a43d204ae6da4cbc57a0be1cbb33241 (diff)
downloadopenembedded-core-contrib-1b7b0c28d8d6a99e7a52feeb0bfce7b5bd305691.tar.gz
python: sync with OE .dev and dropped Tcl/Tk support
- updated to 2.4.4 - cleaned manifest git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1305 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras/packages/python/python-2.4.4/fix-tkinter-detection.patch')
-rw-r--r--meta-extras/packages/python/python-2.4.4/fix-tkinter-detection.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-extras/packages/python/python-2.4.4/fix-tkinter-detection.patch b/meta-extras/packages/python/python-2.4.4/fix-tkinter-detection.patch
new file mode 100644
index 0000000000..602aa8e021
--- /dev/null
+++ b/meta-extras/packages/python/python-2.4.4/fix-tkinter-detection.patch
@@ -0,0 +1,39 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- Python-2.4.1/setup.py~fix-tkinter-detection
++++ Python-2.4.1/setup.py
+@@ -999,7 +999,7 @@
+ dotversion = dotversion[:-1] + '.' + dotversion[-1]
+ tcl_include_sub = []
+ tk_include_sub = []
+- for dir in inc_dirs:
++ for dir in [os.getenv("STAGING_INCDIR")]:
+ tcl_include_sub += [dir + os.sep + "tcl" + dotversion]
+ tk_include_sub += [dir + os.sep + "tk" + dotversion]
+ tk_include_sub += tcl_include_sub
+@@ -1018,22 +1018,6 @@
+ if dir not in include_dirs:
+ include_dirs.append(dir)
+
+- # Check for various platform-specific directories
+- if platform == 'sunos5':
+- include_dirs.append('/usr/openwin/include')
+- added_lib_dirs.append('/usr/openwin/lib')
+- elif os.path.exists('/usr/X11R6/include'):
+- include_dirs.append('/usr/X11R6/include')
+- added_lib_dirs.append('/usr/X11R6/lib64')
+- added_lib_dirs.append('/usr/X11R6/lib')
+- elif os.path.exists('/usr/X11R5/include'):
+- include_dirs.append('/usr/X11R5/include')
+- added_lib_dirs.append('/usr/X11R5/lib')
+- else:
+- # Assume default location for X11
+- include_dirs.append('/usr/X11/include')
+- added_lib_dirs.append('/usr/X11/lib')
+-
+ # If Cygwin, then verify that X is installed before proceeding
+ if platform == 'cygwin':
+ x11_inc = find_file('X11/Xlib.h', [], include_dirs)