aboutsummaryrefslogtreecommitdiffstats
path: root/meta-extras/packages/maemo
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta-extras/packages/maemo
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadopenembedded-core-contrib-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-extras/packages/maemo')
-rw-r--r--meta-extras/packages/maemo/nokia770-init/fixup-770.sh26
-rw-r--r--meta-extras/packages/maemo/nokia770-init_1.0.bb38
-rw-r--r--meta-extras/packages/maemo/xpext/auxdir.patch13
-rw-r--r--meta-extras/packages/maemo/xpext_1.0-5.bb22
-rw-r--r--meta-extras/packages/maemo/xsp_1.0.0-8.bb12
5 files changed, 111 insertions, 0 deletions
diff --git a/meta-extras/packages/maemo/nokia770-init/fixup-770.sh b/meta-extras/packages/maemo/nokia770-init/fixup-770.sh
new file mode 100644
index 0000000000..0f1734d2ab
--- /dev/null
+++ b/meta-extras/packages/maemo/nokia770-init/fixup-770.sh
@@ -0,0 +1,26 @@
+#! /bin/sh
+case "$1" in
+ start)
+ echo -n "Unmounting virtual fs from initrd"
+ umount /mnt/initfs/sys
+ umount /mnt/initfs/proc
+ ln -s /dev/vc/0 /dev/tty0
+ ln -s /dev/vc/1 /dev/tty1
+ ln -s /dev/vc/2 /dev/tty2
+ ln -s /dev/vc/3 /dev/tty3
+ ln -s /dev/vc/4 /dev/tty4
+ ln -s /dev/vc/5 /dev/tty5
+ ln -s /dev/vc/6 /dev/tty6
+ ln -s /dev/vc/7 /dev/tty7
+ /sbin/ifconfig wlan0 up
+ ;;
+ stop)
+ ;;
+ *)
+ echo "Usage: $SCRIPTNAME {start|stop}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
+ \ No newline at end of file
diff --git a/meta-extras/packages/maemo/nokia770-init_1.0.bb b/meta-extras/packages/maemo/nokia770-init_1.0.bb
new file mode 100644
index 0000000000..9075c016a6
--- /dev/null
+++ b/meta-extras/packages/maemo/nokia770-init_1.0.bb
@@ -0,0 +1,38 @@
+LICENSE = "GPL"
+PR = "r7"
+
+DEPENDS = "base-passwd"
+
+SRC_URI = "file://fixup-770.sh"
+
+COMPATIBLE_MACHINE = "(nokia770|nokia800)"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "fixup-770.sh"
+INITSCRIPT_PARAMS = "defaults 01"
+
+FILES_${PN} = "${sysconfdir} ${libdir}"
+
+do_install () {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/fixup-770.sh ${D}/${sysconfdir}/init.d/fixup-770.sh
+
+ install -d ${D}/lib/firmware
+}
+
+pkg_postinst () {
+#!/bin/sh
+
+# set up some links to firmware and modules in initrd
+ mkdir -p $D/lib/firmware
+ ln -sf /mnt/initfs/usr/lib/hotplug/firmware/3825.arm $D/lib/firmware/3825.arm
+ ln -sf /mnt/initfs/usr/lib/hotplug/firmware/3826.arm $D/lib/firmware/3826.arm
+ ln -sf /mnt/initfs/usr/lib/hotplug/firmware/bc4fw.bin $D/lib/firmware/bc4fw.bin
+ ln -sf /mnt/initfs/usr/lib/hotplug/firmware/brf6150fw.bin $D/lib/firmware/brf6150fw.bin
+ ln -sf /mnt/initfs/usr/lib/hotplug/firmware/mtlm3825.arm $D/lib/firmware/mtlm3825.arm
+ ln -sf /mnt/initfs/usr/lib/hotplug/firmware/mtlm3826.arm $D/lib/firmware/mtlm3826.arm
+
+# rm -rf $D/lib/modules
+# ln -s /mnt/initfs/lib/modules $D/lib/modules
+}
diff --git a/meta-extras/packages/maemo/xpext/auxdir.patch b/meta-extras/packages/maemo/xpext/auxdir.patch
new file mode 100644
index 0000000000..da5841a132
--- /dev/null
+++ b/meta-extras/packages/maemo/xpext/auxdir.patch
@@ -0,0 +1,13 @@
+--- configure.ac.old 2005-06-03 12:53:28.000000000 +0200
++++ configure.ac 2005-06-03 12:54:29.000000000 +0200
+@@ -25,9 +25,9 @@
+
+ AC_PREREQ([2.57])
+ AC_INIT([spext], [1.0], [lauri.leukkunen@nokia.com], spext)
++AC_CONFIG_AUX_DIR(.)
+ AM_INIT_AUTOMAKE([dist-bzip2])
+ AM_MAINTAINER_MODE
+-AC_CONFIG_AUX_DIR(.)
+
+ dnl PKG_CHECK_MODULES(FIXESEXT, fixesext)
+
diff --git a/meta-extras/packages/maemo/xpext_1.0-5.bb b/meta-extras/packages/maemo/xpext_1.0-5.bb
new file mode 100644
index 0000000000..5be3d1c041
--- /dev/null
+++ b/meta-extras/packages/maemo/xpext_1.0-5.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "X Server Nokia 770 extensions library"
+LICENSE= "MIT"
+SECTION = "x11/libs"
+PRIORITY = "optional"
+DEPENDS = "virtual/libx11 libxext"
+PR = "r1"
+
+SRC_URI = "http://repository.maemo.org/pool/maemo/ossw/source/x/${PN}/${PN}_${PV}.tar.gz \
+ file://auxdir.patch;patch=1;pnum=0"
+S = "${WORKDIR}/xpext-1.0"
+
+# ${PN} is empty so we need to tweak -dev and -dbg package dependencies
+RDEPENDS_${PN}-dev = ""
+RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPV})"
+
+inherit autotools pkgconfig
+
+do_configure_prepend () {
+ cd ${S}
+ chmod +x ./autogen.sh
+ ./autogen.sh
+}
diff --git a/meta-extras/packages/maemo/xsp_1.0.0-8.bb b/meta-extras/packages/maemo/xsp_1.0.0-8.bb
new file mode 100644
index 0000000000..c722213c86
--- /dev/null
+++ b/meta-extras/packages/maemo/xsp_1.0.0-8.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "X Server Nokia 770 extensions library"
+SECTION = "x11/libs"
+PRIORITY = "optional"
+LICENSE= "MIT"
+DEPENDS = "virtual/libx11 libxext xpext"
+
+PR = "r1"
+
+SRC_URI = "http://repository.maemo.org/pool/maemo/ossw/source/x/xsp/${PN}_${PV}.tar.gz"
+S = "${WORKDIR}/Xsp"
+
+inherit autotools pkgconfig