aboutsummaryrefslogtreecommitdiffstats
path: root/documentation
diff options
context:
space:
mode:
authorScott Rifenbark <scott.m.rifenbark@intel.com>2014-06-19 11:27:12 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-03 13:57:08 +0100
commit1c0229ebc8c12f8214f92c898cd73793ebebf2d0 (patch)
tree70fde81257cf39bcd732a34a342aecd0edde2537 /documentation
parenta548944ecf9ae5e8e631da5539874c631a4e981b (diff)
downloadopenembedded-core-contrib-1c0229ebc8c12f8214f92c898cd73793ebebf2d0.tar.gz
ref-manual: Added TUNE_ARCH variable and edited TARGET_ARCH.
Fixes [YOCTO 5463] Added the TUNE_ARCH variable. Also placed a cross-reference to TUNE_ARCH in the TARGET_ARCH variable. (From yocto-docs rev: 85d2a49323e0040b263b6d7f08fd036a25297b05) Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation')
-rw-r--r--documentation/ref-manual/ref-variables.xml59
1 files changed, 59 insertions, 0 deletions
diff --git a/documentation/ref-manual/ref-variables.xml b/documentation/ref-manual/ref-variables.xml
index 3bd7f9ddd7..a811a63cbd 100644
--- a/documentation/ref-manual/ref-variables.xml
+++ b/documentation/ref-manual/ref-variables.xml
@@ -8200,6 +8200,10 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
mips
mipsel
</literallayout>
+ For additional information on machine architectures, see
+ the
+ <link linkend='var-TUNE_ARCH'><filename>TUNE_ARCH</filename></link>
+ variable.
</para>
</glossdef>
</glossentry>
@@ -8796,6 +8800,61 @@ recipes-graphics/xorg-font/font-alias_1.0.3.bb:PR = "${INC_PR}.3"
</glossdef>
</glossentry>
+ <glossentry id='var-TUNE_ARCH'><glossterm>TUNE_ARCH</glossterm>
+ <glossdef>
+ <para>
+ The GNU canonical architecture for a specific architecture
+ (i.e. <filename>arm</filename>,
+ <filename>armeb</filename>,
+ <filename>mips</filename>,
+ <filename>mips64</filename>, and so forth).
+ BitBake uses this value to setup configuration.
+ </para>
+
+ <para>
+ <filename>TUNE_ARCH</filename> definitions are specific to
+ a given architecture.
+ The definitions can be a single static definition, or
+ can be dynamically adjusted.
+ You can see details for a given CPU family by looking at
+ the architecture's <filename>README</filename> file.
+ For example, the
+ <filename>meta/conf/machine/include/mips/README</filename>
+ file in the
+ <ulink url='&YOCTO_DOCS_DEV_URL;#source-directory'>Source Directory</ulink>
+ provides information for <filename>TUNE_ARCH</filename>
+ specific to the <filename>mips</filename> architecture.
+ </para>
+
+ <para>
+ <filename>TUNE_ARCH</filename> is tied closely to
+ <link linkend='var-TARGET_ARCH'><filename>TARGET_ARCH</filename></link>,
+ which defines the target machine's architecture.
+ The BitBake configuration file
+ (<filename>meta/conf/bitbake.conf</filename>) sets
+ <filename>TARGET_ARCH</filename> as follows:
+ <literallayout class='monospaced'>
+ TARGET_ARCH = "${TUNE_ARCH}"
+ </literallayout>
+ </para>
+
+ <para>
+ The following list, which is by no means complete since
+ architectures are configurable, shows supported machine
+ architectures:
+ <literallayout class='monospaced'>
+ arm
+ i586
+ x86_64
+ powerpc
+ powerpc64
+ mips
+ mipsel
+ </literallayout>
+ </para>
+ </glossdef>
+ </glossentry>
+
<glossentry id='var-TUNE_CCARGS'><glossterm>TUNE_CCARGS</glossterm>
<glossdef>
<para>