aboutsummaryrefslogtreecommitdiffstats
path: root/documentation
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-10-22 13:50:14 +0100
committerJoshua Lock <josh@linux.intel.com>2010-10-22 13:56:31 +0100
commiteef1d813b7248ba40eb958f4052dbe4d52b93591 (patch)
treecc3a9db295ff47c10af011ba6119e23b7577ef33 /documentation
parent36f1ae42fe13dae174b7fb5eb85dc49d7d7b516b (diff)
downloadopenembedded-core-contrib-eef1d813b7248ba40eb958f4052dbe4d52b93591.tar.gz
documentation/bsp: update to reference FILESEXTRAPATHS
It's no longer neccesarry to define THISDIR and FILESPATH in each bbappend recipe. Should you need to reference extra files you should use FILESEXTRAPATHS Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'documentation')
-rw-r--r--documentation/poky-ref-manual/bsp.xml8
1 files changed, 4 insertions, 4 deletions
diff --git a/documentation/poky-ref-manual/bsp.xml b/documentation/poky-ref-manual/bsp.xml
index 9982f9e739..acb9f38e19 100644
--- a/documentation/poky-ref-manual/bsp.xml
+++ b/documentation/poky-ref-manual/bsp.xml
@@ -284,13 +284,13 @@ meta-bsp/packages/image-creator/image-creator-native_0.1.bb
This allows the BSP layer to poke around and do whatever it might want to customise
the original recipe.
- .bbappend is expected to include the below two lines in the head (which may be changed
- in the future):
+ If your recipe needs to reference extra files it can use the FILESEXTRAPATH variable
+ to specify their location. The example below shows extra files contained in a folder
+ called ${PN} (the package name).
</para>
<programlisting>
-THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
-FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:"
+FILESEXTRAPATHS := "${THISDIR}/${PN}"
</programlisting>
<para>