aboutsummaryrefslogtreecommitdiffstats
path: root/documentation/ref-manual/usingpoky.xml
diff options
context:
space:
mode:
authorScott Rifenbark <scott.m.rifenbark@intel.com>2013-11-06 08:55:06 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-03 12:53:04 +0000
commit4a5282213f00bc7361ee69930426debda1e83584 (patch)
treea5a6ece67b0f7d49ec34a5c3e3adab95ee303cbb /documentation/ref-manual/usingpoky.xml
parentf16706d936bf1842448b64029581ed214069a94c (diff)
downloadopenembedded-core-contrib-4a5282213f00bc7361ee69930426debda1e83584.tar.gz
ref-manual: Updates to "Variables" and "Building with No Dependencies"
There was some confusion over some things in these two sections. I re-wrote them with the help of Paul Eggleton to be clear on them. Reported-by: Robert P. J. Day (rpjday@crashcourse.ca> (From yocto-docs rev: ab352523e82626d8356d8b2c07fb10d2d60ea254) Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation/ref-manual/usingpoky.xml')
-rw-r--r--documentation/ref-manual/usingpoky.xml33
1 files changed, 22 insertions, 11 deletions
diff --git a/documentation/ref-manual/usingpoky.xml b/documentation/ref-manual/usingpoky.xml
index 1edc9ea238..49166e15bf 100644
--- a/documentation/ref-manual/usingpoky.xml
+++ b/documentation/ref-manual/usingpoky.xml
@@ -271,12 +271,18 @@
<section id='usingpoky-debugging-buildfile'>
<title>Building with No Dependencies</title>
<para>
- If you really want to build a specific <filename>.bb</filename> file, you can use
- the command form <filename>bitbake -b &lt;somepath/somefile.bb&gt;</filename>.
- This command form does not check for dependencies so you should use it
- only when you know its dependencies already exist.
- You can also specify fragments of the filename.
- In this case, BitBake checks for a unique match.
+ To build a specific recipe (<filename>.bb</filename> file),
+ you can use the following command form:
+ <literallayout class='monospaced'>
+ $ bitbake -b &lt;somepath/somerecipe.bb&gt;
+ </literallayout>
+ This command form does not check for dependencies.
+ Consequently, you should use it
+ only when you know dependencies already exist.
+ <note>
+ You can also specify fragments of the filename.
+ In this case, BitBake checks for a unique match.
+ </note>
</para>
</section>
@@ -284,11 +290,16 @@
<title>Variables</title>
<para>
You can use the <filename>-e</filename> BitBake option to
- display the resulting environment for a configuration
- when you do not specify a package or for a specific package when
- you do specify the package.
- If you want to show the environment resulting from parsing a single
- recipe, use the <filename>-b recipename</filename> form.
+ display the parsing environment for a configuration.
+ The following displays the general parsing environment:
+ <literallayout class='monospaced'>
+ $ bitbake -e
+ </literallayout>
+ This next example shows the parsing environment for a specific
+ recipe:
+ <literallayout class='monospaced'>
+ $ bitbake -e &lt;recipename&gt;
+ </literallayout>
</para>
</section>