aboutsummaryrefslogtreecommitdiffstats
path: root/documentation/kernel-dev
diff options
context:
space:
mode:
authorScott Rifenbark <scott.m.rifenbark@intel.com>2015-02-25 08:46:19 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-27 07:40:34 +0000
commit4bdaa5c5baf9b3f6306e8f2452155546d1f9730a (patch)
treee719500dd943c8e5ecbbe4f093725830a2afb24e /documentation/kernel-dev
parent1a74c797a00f5870330fb1e2d6aaf36cca44ccc5 (diff)
downloadopenembedded-core-contrib-4bdaa5c5baf9b3f6306e8f2452155546d1f9730a.tar.gz
kernel-dev: Small fixes.
Reported-by: Robert P. J. Day <rpjday@crashcourse.ca> (From yocto-docs rev: 198ce97a1158237056f035ade555ce04a6031c56) Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation/kernel-dev')
-rw-r--r--documentation/kernel-dev/kernel-dev-common.xml22
1 files changed, 11 insertions, 11 deletions
diff --git a/documentation/kernel-dev/kernel-dev-common.xml b/documentation/kernel-dev/kernel-dev-common.xml
index b08f7983f0..56fa17d7d8 100644
--- a/documentation/kernel-dev/kernel-dev-common.xml
+++ b/documentation/kernel-dev/kernel-dev-common.xml
@@ -133,16 +133,16 @@
<para>
For example, you can apply a three-patch series by adding the
- following lines to your linux-yocto <filename>.bbappend</filename>
- file in your layer:
+ following lines to your linux-yocto
+ <filename>.bbappend</filename> file in your layer:
<literallayout class='monospaced'>
SRC_URI += "file://0001-first-change.patch"
- SRC_URI += "file://0002-first-change.patch"
- SRC_URI += "file://0003-first-change.patch"
+ SRC_URI += "file://0002-second-change.patch"
+ SRC_URI += "file://0003-third-change.patch"
</literallayout>
- The next time you run BitBake to build the Linux kernel, BitBake
- detects the change in the recipe and fetches and applies the patches
- before building the kernel.
+ The next time you run BitBake to build the Linux kernel,
+ BitBake detects the change in the recipe and fetches and
+ applies the patches before building the kernel.
</para>
<para>
@@ -187,14 +187,14 @@
<note>
The build system applies the configurations from the
- <filename>.config</filename> file before applying any
+ <filename>defconfig</filename> file before applying any
subsequent configuration fragments.
The final kernel configuration is a combination of the
- configurations in the <filename>.config</filename> file and
+ configurations in the <filename>defconfig</filename> file and
any configuration fragments you provide.
You need to realize that if you have any configuration
fragments, the build system applies these on top of and
- after applying the existing <filename>.config</filename>
+ after applying the existing <filename>defconfig</filename>
file configurations.
</note>
@@ -399,7 +399,7 @@
WARNING: There were 2 hardware options requested that do not
have a corresponding value present in the final ".config" file.
- This probably means you are not't getting the config you wanted.
+ This probably means you are not getting the config you wanted.
The full list can be found in your kernel src dir at:
meta/cfg/standard/mybsp/mismatch.cfg
</literallayout>