aboutsummaryrefslogtreecommitdiffstats
path: root/documentation/kernel-dev/kernel-dev-faq.xml
diff options
context:
space:
mode:
authorScott Rifenbark <scott.m.rifenbark@intel.com>2014-06-06 12:29:19 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-18 10:30:47 +0100
commit1d870a7c23144341337eb7f836e082d1a82a3dc5 (patch)
tree04938dda41c0aaf9a30010c1ab38a6f1bb595d45 /documentation/kernel-dev/kernel-dev-faq.xml
parent2f7fc0015f156b73b5e5261cfb9c370ca5e2a031 (diff)
downloadopenembedded-core-contrib-1d870a7c23144341337eb7f836e082d1a82a3dc5.tar.gz
kernel-dev: Added an embedded section.
Not having a section was messing up the TOC for the FAQ in the mega-manual. I added a section. (From yocto-docs rev: d4a34cb1815e3e12e73e08b5ae7b2027b5f03823) Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation/kernel-dev/kernel-dev-faq.xml')
-rw-r--r--documentation/kernel-dev/kernel-dev-faq.xml225
1 files changed, 117 insertions, 108 deletions
diff --git a/documentation/kernel-dev/kernel-dev-faq.xml b/documentation/kernel-dev/kernel-dev-faq.xml
index 7389c9c9c5..2b99ad2dde 100644
--- a/documentation/kernel-dev/kernel-dev-faq.xml
+++ b/documentation/kernel-dev/kernel-dev-faq.xml
@@ -4,127 +4,136 @@
<appendix id='kernel-dev-faq'>
<title>Kernel Development FAQ</title>
-<qandaset>
- <qandaentry>
- <question>
- <para>
- How do I use my own Linux kernel <filename>.config</filename>
- file?
- </para>
- </question>
- <answer>
- <para>
- Refer to the "<link linkend='changing-the-configuration'>Changing the Configuration</link>"
- section for information.
- </para>
- </answer>
- </qandaentry>
- <qandaentry>
- <question>
- <para>
- How do I create configuration fragments?
- </para>
- </question>
- <answer>
- <para>
- Refer to the "<link linkend='generating-configuration-files'>Generating Configuration Files</link>"
- section for information.
- </para>
- </answer>
- </qandaentry>
+<section id='kernel-dev-faq-section'>
+ <title>Common Questions and Solutions</title>
- <qandaentry>
- <question>
- <para>
- How do I use my own Linux kernel sources?
- </para>
- </question>
- <answer>
- <para>
- Refer to the "<link linkend='working-with-your-own-sources'>Working With Your Own Sources</link>"
- section for information.
- </para>
- </answer>
- </qandaentry>
+ <para>
+ The following lists some solutions for common questions.
- <qandaentry>
- <question>
- <para>
- How do I install/not-install the kernel image on the rootfs?
- </para>
- </question>
- <answer>
- <para>
- The kernel image (e.g. <filename>vmlinuz</filename>) is provided
- by the <filename>kernel-image</filename> package.
- Image recipes depend on <filename>kernel-base</filename>.
- To specify whether or not the kernel
- image is installed in the generated root filesystem, override
- <filename>RDEPENDS_kernel-base</filename> to include or not
- include "kernel-image".</para>
- <para>See the
- "<ulink url='&YOCTO_DOCS_DEV_URL;#using-bbappend-files'>Using .bbappend Files</ulink>"
- section in the Yocto Project Development Manual for information on
- how to use an append file to override metadata.
- </para>
- </answer>
- </qandaentry>
- <qandaentry>
- <question>
+ <qandaset>
+ <qandaentry>
+ <question>
+ <para>
+ How do I use my own Linux kernel <filename>.config</filename>
+ file?
+ </para>
+ </question>
+ <answer>
<para>
- How do I install a specific kernel module?
- </para>
- </question>
- <answer>
- <para>
- Linux kernel modules are packaged individually.
- To ensure a specific kernel module is included in an image,
- include it in the appropriate machine
- <ulink url='&YOCTO_DOCS_REF_URL;#var-RRECOMMENDS'><filename>RRECOMMENDS</filename></ulink>
- variable.</para>
- <para>These other variables are useful for installing specific
- modules:
- <literallayout class='monospaced'>
+ Refer to the "<link linkend='changing-the-configuration'>Changing the Configuration</link>"
+ section for information.
+ </para>
+ </answer>
+ </qandaentry>
+
+ <qandaentry>
+ <question>
+ <para>
+ How do I create configuration fragments?
+ </para>
+ </question>
+ <answer>
+ <para>
+ Refer to the "<link linkend='generating-configuration-files'>Generating Configuration Files</link>"
+ section for information.
+ </para>
+ </answer>
+ </qandaentry>
+
+ <qandaentry>
+ <question>
+ <para>
+ How do I use my own Linux kernel sources?
+ </para>
+ </question>
+ <answer>
+ <para>
+ Refer to the "<link linkend='working-with-your-own-sources'>Working With Your Own Sources</link>"
+ section for information.
+ </para>
+ </answer>
+ </qandaentry>
+
+ <qandaentry>
+ <question>
+ <para>
+ How do I install/not-install the kernel image on the rootfs?
+ </para>
+ </question>
+ <answer>
+ <para>
+ The kernel image (e.g. <filename>vmlinuz</filename>) is provided
+ by the <filename>kernel-image</filename> package.
+ Image recipes depend on <filename>kernel-base</filename>.
+ To specify whether or not the kernel
+ image is installed in the generated root filesystem, override
+ <filename>RDEPENDS_kernel-base</filename> to include or not
+ include "kernel-image".</para>
+ <para>See the
+ "<ulink url='&YOCTO_DOCS_DEV_URL;#using-bbappend-files'>Using .bbappend Files</ulink>"
+ section in the Yocto Project Development Manual for information on
+ how to use an append file to override metadata.
+ </para>
+ </answer>
+ </qandaentry>
+
+ <qandaentry>
+ <question>
+ <para>
+ How do I install a specific kernel module?
+ </para>
+ </question>
+ <answer>
+ <para>
+ Linux kernel modules are packaged individually.
+ To ensure a specific kernel module is included in an image,
+ include it in the appropriate machine
+ <ulink url='&YOCTO_DOCS_REF_URL;#var-RRECOMMENDS'><filename>RRECOMMENDS</filename></ulink>
+ variable.</para>
+ <para>These other variables are useful for installing specific
+ modules:
+ <literallayout class='monospaced'>
<ulink url='&YOCTO_DOCS_REF_URL;#var-MACHINE_ESSENTIAL_EXTRA_RDEPENDS'><filename>MACHINE_ESSENTIAL_EXTRA_RDEPENDS</filename></ulink>
<ulink url='&YOCTO_DOCS_REF_URL;#var-MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS'><filename>MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS</filename></ulink>
<ulink url='&YOCTO_DOCS_REF_URL;#var-MACHINE_EXTRA_RDEPENDS'><filename>MACHINE_EXTRA_RDEPENDS</filename></ulink>
<ulink url='&YOCTO_DOCS_REF_URL;#var-MACHINE_EXTRA_RRECOMMENDS'><filename>MACHINE_EXTRA_RRECOMMENDS</filename></ulink>
- </literallayout>
- For example, set the following in the <filename>qemux86.conf</filename>
- file to include the <filename>ab123</filename> kernel modules
- with images built for the <filename>qemux86</filename> machine:
- <literallayout class='monospaced'>
+ </literallayout>
+ For example, set the following in the <filename>qemux86.conf</filename>
+ file to include the <filename>ab123</filename> kernel modules
+ with images built for the <filename>qemux86</filename> machine:
+ <literallayout class='monospaced'>
MACHINE_EXTRA_RRECOMMENDS += "kernel-module-ab123"
- </literallayout>
- For more information, see the
- "<link linkend='incorporating-out-of-tree-modules'>Incorporating Out-of-Tree Modules</link>"
- section.
- </para>
- </answer>
- </qandaentry>
+ </literallayout>
+ For more information, see the
+ "<link linkend='incorporating-out-of-tree-modules'>Incorporating Out-of-Tree Modules</link>"
+ section.
+ </para>
+ </answer>
+ </qandaentry>
- <qandaentry>
- <question>
- <para>
- How do I change the Linux kernel command line?
- </para>
- </question>
- <answer>
- <para>
- The Linux kernel command line is typically specified in
- the machine config using the <filename>APPEND</filename> variable.
+ <qandaentry>
+ <question>
+ <para>
+ How do I change the Linux kernel command line?
+ </para>
+ </question>
+ <answer>
+ <para>
+ The Linux kernel command line is typically specified in
+ the machine config using the <filename>APPEND</filename> variable.
For example, you can add some helpful debug information doing
- the following:
- <literallayout class='monospaced'>
+ the following:
+ <literallayout class='monospaced'>
APPEND += "printk.time=y initcall_debug debug"
- </literallayout>
- </para>
- </answer>
- </qandaentry>
-
-</qandaset>
+ </literallayout>
+ </para>
+ </answer>
+ </qandaentry>
+ </qandaset>
+ </para>
+</section>
</appendix>
<!--
vim: expandtab tw=80 ts=4