aboutsummaryrefslogtreecommitdiffstats
path: root/documentation/dev-manual
diff options
context:
space:
mode:
authorScott Rifenbark <srifenbark@gmail.com>2016-09-21 11:44:43 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-28 15:02:32 +0100
commit959a0620961d5404f826d3545109bb08057fe391 (patch)
tree6baf56b4e7b2b29ff6a746e2ec058d7af4a24eab /documentation/dev-manual
parent4404fc3fe05ad5dd899c1952c1f90f0bb3630f40 (diff)
downloadopenembedded-core-contrib-959a0620961d5404f826d3545109bb08057fe391.tar.gz
sdk-manual, dev-manual: Applied SDK review edits.
* Removed the note box formatting for the cross-reference from the sdk-manual and dev-manual sections that talk about devtool. The reference is now non-note form and goes to the ref-manual devtool quick ref. * Added devtool upgrade as a third item in the list that introduces methods to use devtool. * Fixed the working on the devtool finish step 5 for both the dev-manual and sdk-manual. * Renamed the new chapter that describes different projects you can use devtool on. The focus is on using the SDK toolchain directly. * Scrubbed the entire sdk-manual for the term "toolchain installer" and replaced with "SDK installer". (From yocto-docs rev: 6d4daef49cc6d54a700a8c3965c9e8814f75d20a) Signed-off-by: Scott Rifenbark <srifenbark@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation/dev-manual')
-rw-r--r--documentation/dev-manual/dev-manual-model.xml22
1 files changed, 11 insertions, 11 deletions
diff --git a/documentation/dev-manual/dev-manual-model.xml b/documentation/dev-manual/dev-manual-model.xml
index 1edead3d6b..0b76ad7191 100644
--- a/documentation/dev-manual/dev-manual-model.xml
+++ b/documentation/dev-manual/dev-manual-model.xml
@@ -646,12 +646,10 @@
<para>
The remainder of this section presents these workflows.
- <note>
- See the
- "<ulink url='&YOCTO_DOCS_REF_URL;#ref-devtool-reference'><filename>devtool</filename>&nbsp;Quick Reference</ulink>"
- in the Yocto Project Reference Manual for more a
- <filename>devtool</filename> reference.
- </note>
+ See the
+ "<ulink url='&YOCTO_DOCS_REF_URL;#ref-devtool-reference'><filename>devtool</filename>&nbsp;Quick Reference</ulink>"
+ in the Yocto Project Reference Manual for a
+ <filename>devtool</filename> quick reference.
</para>
<section id='use-devtool-to-integrate-new-code'>
@@ -1227,11 +1225,13 @@
<emphasis>Finish Your Work With the Recipe</emphasis>:
The <filename>devtool finish</filename> command creates
any patches corresponding to commits in the local
- Git repository, updates the recipe to point to them
- (or creates a <filename>.bbappend</filename> file to do
- so, depending on the specified destination layer), and
- then resets the recipe so that the recipe is built normally
- rather than from the workspace.
+ Git repository, moves the new recipe to a more permanent
+ layer, and then resets the recipe so that the recipe is
+ built normally rather than from the workspace.
+ If you specify a destination layer that is the same as
+ the original source, then the old version of the
+ recipe and associated files will be removed prior to
+ adding the new version.
<literallayout class='monospaced'>
$ devtool finish <replaceable>recipe layer</replaceable>
</literallayout>