aboutsummaryrefslogtreecommitdiffstats
path: root/documentation/bsp-guide
diff options
context:
space:
mode:
authorScott Rifenbark <scott.m.rifenbark@intel.com>2015-01-05 13:50:07 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-06 14:27:01 +0000
commite38e7e7c79b01a99796db662b992527b93fea612 (patch)
tree38c9658f832218912d3d3f45a90ecd1ec723d880 /documentation/bsp-guide
parent63e44521ef72834835b8bf7ffd855538e67abfa1 (diff)
downloadopenembedded-core-contrib-e38e7e7c79b01a99796db662b992527b93fea612.tar.gz
bsp-guide: Some corrections to the Crown Bay code examples.
The directory structure no longer seems to support two flavors of the BSP: one with EMGD and the "noemgd." Only the "noemgd" remains. I have updated some of the examples here to reflect the current directory structure and sample configuration code for the BSP. Reported-by: Robert P. J. Day <rpjday@crashcourse.ca> (From yocto-docs rev: 64fc4a7a6d69eb99dcd3d8c5e388810e7052ad75) Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation/bsp-guide')
-rw-r--r--documentation/bsp-guide/bsp.xml37
1 files changed, 20 insertions, 17 deletions
diff --git a/documentation/bsp-guide/bsp.xml b/documentation/bsp-guide/bsp.xml
index d4850234d1..7055a21168 100644
--- a/documentation/bsp-guide/bsp.xml
+++ b/documentation/bsp-guide/bsp.xml
@@ -200,25 +200,17 @@
meta-crownbay/conf/
meta-crownbay/conf/layer.conf
meta-crownbay/conf/machine/
- meta-crownbay/conf/machine/crownbay.conf
meta-crownbay/conf/machine/crownbay-noemgd.conf
meta-crownbay/recipes-bsp/
meta-crownbay/recipes-bsp/formfactor/
meta-crownbay/recipes-bsp/formfactor/formfactor_0.0.bbappend
meta-crownbay/recipes-bsp/formfactor/formfactor/
- meta-crownbay/recipes-bsp/formfactor/formfactor/crownbay/
- meta-crownbay/recipes-bsp/formfactor/formfactor/crownbay/machconfig
meta-crownbay/recipes-bsp/formfactor/formfactor/crownbay-noemgd/
meta-crownbay/recipes-bsp/formfactor/formfactor/crownbay-noemgd/machconfig
- meta-crownbay/recipes-graphics/
- meta-crownbay/recipes-graphics/xorg-xserver/
- meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
- meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config/
- meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config/crownbay/
- meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config/crownbay/xorg.conf
meta-crownbay/recipes-kernel/
+ meta-crownbay/recipes-kernel/kmod
+ meta-crownbay/recipes-kernel/kmod/kmod_git.bbappend
meta-crownbay/recipes-kernel/linux/
- meta-crownbay/recipes-kernel/linux/linux-yocto-dev.bbappend
meta-crownbay/recipes-kernel/linux/linux-yocto-rt_3.10.bbappend
meta-crownbay/recipes-kernel/linux/linux-yocto_3.10.bbappend
</literallayout>
@@ -351,9 +343,11 @@
BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
${LAYERDIR}/recipes-*/*/*.bbappend"
- BBFILE_COLLECTIONS += "bsp"
- BBFILE_PATTERN_bsp = "^${LAYERDIR}/"
- BBFILE_PRIORITY_bsp = "6"
+ BBFILE_COLLECTIONS += "<replaceable>bsp</replaceable>"
+ BBFILE_PATTERN_<replaceable>bsp</replaceable> = "^${LAYERDIR}/"
+ BBFILE_PRIORITY_<replaceable>bsp</replaceable> = "6"
+
+ LAYERDEPENDS_<replaceable>bsp</replaceable> = "intel"
</literallayout>
</para>
@@ -361,9 +355,18 @@
To illustrate the string substitutions, here are the corresponding statements
from the Crown Bay <filename>conf/layer.conf</filename> file:
<literallayout class='monospaced'>
+ # We have a conf and classes directory, add to BBPATH
+ BBPATH .= ":${LAYERDIR}"
+
+ # We have a recipes directory, add to BBFILES
+ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
BBFILE_COLLECTIONS += "crownbay"
- BBFILE_PATTERN_crownbay = "^${LAYERDIR}/"
+ BBFILE_PATTERN_crownbay := "^${LAYERDIR}/"
BBFILE_PRIORITY_crownbay = "6"
+
+ LAYERDEPENDS_crownbay = "intel"
</literallayout>
</para>
@@ -425,12 +428,12 @@
<para>
To use an include file, you simply include them in the machine configuration file.
- For example, the Crown Bay BSP <filename>crownbay.conf</filename> contains the
+ For example, the Crown Bay BSP <filename>crownbay-noemgd.conf</filename> contains the
following statements:
<literallayout class='monospaced'>
- require conf/machine/include/intel-core2-32-common.inc
require conf/machine/include/meta-intel.inc
- require conf/machine/include/meta-intel-emgd.inc
+ require conf/machine/include/intel-core2-32-common.inc
+ require conf/machine/include/intel-common-pkgarch.inc
</literallayout>
</para>
</section>