aboutsummaryrefslogtreecommitdiffstats
path: root/documentation/bsp-guide
diff options
context:
space:
mode:
authorScott Rifenbark <scott.m.rifenbark@intel.com>2015-01-05 14:54:50 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-06 14:27:02 +0000
commit54f98c05258ad7c01afa27427bc1a6eea2388716 (patch)
treeb49239b555c1ed30dbe211463536e01ff856ef43 /documentation/bsp-guide
parenteae11ba551e5de16a47f827e25fd6af055323863 (diff)
downloadopenembedded-core-contrib-54f98c05258ad7c01afa27427bc1a6eea2388716.tar.gz
bsp-guide: Cleaned up some examples affected by VESA-support
The Crown Bay BSP now only supports VESA graphics. Because of this, some of the examples in several areas of the BSP hierarchy were wrong. Changed accordingly. Reported-by: Robert P. J. Day <rpjday@crashcourse.ca> (From yocto-docs rev: b61f013a086a9135a86eedf2884fd1b07f798165) Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation/bsp-guide')
-rw-r--r--documentation/bsp-guide/bsp.xml46
1 files changed, 17 insertions, 29 deletions
diff --git a/documentation/bsp-guide/bsp.xml b/documentation/bsp-guide/bsp.xml
index b2b13148f8..e2262a41f8 100644
--- a/documentation/bsp-guide/bsp.xml
+++ b/documentation/bsp-guide/bsp.xml
@@ -456,11 +456,10 @@
append file used to augment the recipe that starts the build.
Furthermore, there are machine-specific settings used during the
build that are defined by the <filename>machconfig</filename> file.
- In the Crown Bay example, two <filename>machconfig</filename> files
- exist: one that supports the Intel® Embedded Media and Graphics
- Driver (Intel® EMGD) and one that does not:
+ In the Crown Bay example, the <filename>machconfig</filename> file
+ supports the Video Electronics Standards Association (VESA) graphics
+ driver:
<literallayout class='monospaced'>
- meta-crownbay/recipes-bsp/formfactor/formfactor/crownbay/machconfig
meta-crownbay/recipes-bsp/formfactor/formfactor/crownbay-noemgd/machconfig
meta-crownbay/recipes-bsp/formfactor/formfactor_0.0.bbappend
</literallayout>
@@ -489,13 +488,17 @@
This optional directory contains recipes for the BSP if it has
special requirements for graphics support.
All files that are needed for the BSP to support a display are kept here.
- For example, the Crown Bay BSP's <filename>xorg.conf</filename> file
- detects the graphics support needed (i.e. the Intel® Embedded Media
- Graphics Driver (EMGD) or the Video Electronics Standards Association
- (VESA) graphics):
+ For example, the <filename>meta-emenlow</filename> layer, which supports
+ the eMenlow platform consisting of the
+ <trademark class='registered'>Intel</trademark>
+ <trademark class='trade'>Atom</trademark>
+ Z5xx processor with the
+ <trademark class='registered'>Intel</trademark>
+ System Controller Hub US15W uses these files for supporting the Video
+ Electronics Standards Association (VESA) graphics:
<literallayout class='monospaced'>
- meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
- meta-crownbay/recipes-graphics/xorg-xserver/xserver-xf86-config/crownbay/xorg.conf
+ meta-emenlow/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
+ meta-emenlow/recipes-graphics/xorg-xserver/xserver-xf86-config/emenlow-noemgd/xorg.conf
</literallayout>
</para>
</section>
@@ -552,26 +555,14 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
- COMPATIBLE_MACHINE_crownbay = "crownbay"
- KMACHINE_crownbay = "crownbay"
- KBRANCH_crownbay = "standard/crownbay"
- KERNEL_FEATURES_append_crownbay = " features/drm-emgd/drm-emgd-1.18 cfg/vesafb"
-
COMPATIBLE_MACHINE_crownbay-noemgd = "crownbay-noemgd"
KMACHINE_crownbay-noemgd = "crownbay"
KBRANCH_crownbay-noemgd = "standard/crownbay"
KERNEL_FEATURES_append_crownbay-noemgd = " cfg/vesafb"
- LINUX_VERSION_crownbay = "3.10.35"
- SRCREV_meta_crownbay = "b6e58b33dd427fe471f8827c83e311acdf4558a4"
- SRCREV_machine_crownbay = "cee957655fe67826b2e827e2db41f156fa8f0cc4"
- SRCREV_emgd_crownbay = "42d5e4548e8e79e094fa8697949eed4cf6af00a3"
-
- LINUX_VERSION_crownbay-noemgd = "3.10.35"
- SRCREV_meta_crownbay-noemgd = "b6e58b33dd427fe471f8827c83e311acdf4558a4"
- SRCREV_machine_crownbay-noemgd = "cee957655fe67826b2e827e2db41f156fa8f0cc4"
-
- SRC_URI_crownbay = "git://git.yoctoproject.org/linux-yocto-3.10.git;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},emgd-1.18;name=machine,meta,emgd"
+ LINUX_VERSION_crownbay-noemgd = "3.10.55"
+ SRCREV_meta_crownbay-noemgd = "f79a00265eefbe2fffc2cdb03f67235497a9a87e"
+ SRCREV_machine_crownbay-noemgd = "3677ea7f9476458aa6dec440243de3a6fb1343a9"
</literallayout>
This append file contains statements used to support the Crown Bay BSP.
The file defines machines using the
@@ -587,14 +578,11 @@
The
<ulink url='&YOCTO_DOCS_REF_URL;#var-KERNEL_FEATURES'><filename>KERNEL_FEATURES</filename></ulink>
variable enables features specific to the kernel
- (e.g. graphics support in this case).
+ (e.g. VESA graphics support in this case).
The append file points to specific commits in the
<ulink url='&YOCTO_DOCS_DEV_URL;#source-directory'>Source Directory</ulink> Git
repository and the <filename>meta</filename> Git repository branches to identify the
exact kernel needed to build the Crown Bay BSP.
- Finally, the file includes the
- <ulink url='&YOCTO_DOCS_REF_URL;#var-SRC_URI'><filename>SRC_URI</filename></ulink>
- statement to locate the source files.
</para>
<para>