aboutsummaryrefslogtreecommitdiffstats
path: root/documentation/bsp-guide
diff options
context:
space:
mode:
authorScott Rifenbark <scott.m.rifenbark@intel.com>2015-01-05 17:40:15 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-06 14:27:02 +0000
commit060d30ded8684e45f9b5481b137d4cee7b32a87c (patch)
tree07fa5c6c1eb001ed45fc012ed22a409eb9207d85 /documentation/bsp-guide
parent54f98c05258ad7c01afa27427bc1a6eea2388716 (diff)
downloadopenembedded-core-contrib-060d30ded8684e45f9b5481b137d4cee7b32a87c.tar.gz
bsp-guide: Added more detail for customizing a BSP recipe
The way the explanation for adding the BSP-specific files did not take into account for layers that might support multiple machines versus a layer not supporting multiple machines. I added more explanation that covers both scenarios to be clear. Reported-by: Robert P. J. Day <rpjday@crashcourse.ca> (From yocto-docs rev: 3f00f0bb830665f8711c68aa6110b8399e867345) Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation/bsp-guide')
-rw-r--r--documentation/bsp-guide/bsp.xml25
1 files changed, 21 insertions, 4 deletions
diff --git a/documentation/bsp-guide/bsp.xml b/documentation/bsp-guide/bsp.xml
index e2262a41f8..3cda0f6b70 100644
--- a/documentation/bsp-guide/bsp.xml
+++ b/documentation/bsp-guide/bsp.xml
@@ -902,8 +902,15 @@
<filename>recipes-bsp</filename>, <filename>recipes-graphics</filename>,
<filename>recipes-core</filename>, and so forth).
</para></listitem>
- <listitem><para>Place the BSP-specific files in the directory named for
- your machine inside the BSP layer.
+ <listitem><para>Place the BSP-specific files in the proper directory
+ inside the BSP layer.
+ How expansive the layer is affects where you must place these files.
+ For example, if your layer supports several different machine types,
+ you need to be sure your layer's directory structure includes hierarchy
+ that separates the files out according to machine.
+ If your layer does not support multiple machines, the layer would not
+ have that additional hierarchy and the files would obviously not be
+ able to reside in a machine-specific directory.
</para></listitem>
</itemizedlist>
</para>
@@ -912,7 +919,8 @@
Following is a specific example to help you better understand the process.
Consider an example that customizes a recipe by adding
a BSP-specific configuration file named <filename>interfaces</filename> to the
- <filename>init-ifupdown_1.0.bb</filename> recipe for machine "xyz".
+ <filename>init-ifupdown_1.0.bb</filename> recipe for machine "xyz" where the
+ BSP layer also supports several other machines.
Do the following:
<orderedlist>
<listitem><para>Edit the <filename>init-ifupdown_1.0.bbappend</filename> file so that it
@@ -926,8 +934,17 @@
<listitem><para>Create and place the new <filename>interfaces</filename>
configuration file in the BSP's layer here:
<literallayout class='monospaced'>
- meta-xyz/recipes-core/init-ifupdown/files/xyz/interfaces
+ meta-xyz/recipes-core/init-ifupdown/files/xyz-machine-one/interfaces
</literallayout>
+ <note>
+ If the <filename>meta-xyz</filename> layer did not support
+ multiple machines, you would place the
+ <filename>interfaces</filename> configuration file in the
+ layer here:
+ <literallayout class='monospaced'>
+ meta-xyz/recipes-core/init-ifupdown/files/interfaces
+ </literallayout>
+ </note>
The
<ulink url='&YOCTO_DOCS_REF_URL;#var-FILESEXTRAPATHS'><filename>FILESEXTRAPATHS</filename></ulink>
variable in the append files extends the search path