aboutsummaryrefslogtreecommitdiffstats
path: root/documentation/Makefile
diff options
context:
space:
mode:
authorTimo Mueller <timo.mueller@bmw-carit.de>2012-11-30 09:59:28 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-14 15:29:51 +0000
commit42b9f2cafe60cea90d5be877739a99028ce3073d (patch)
treee8a17fa83a2635899b1e766e1aba7dd16dde4105 /documentation/Makefile
parentc94fd49bfc59cbe5733701c75a01ca22a57b4509 (diff)
downloadopenembedded-core-contrib-42b9f2cafe60cea90d5be877739a99028ce3073d.tar.gz
documentation/Makefile: logic to make all for dev manual and cleanup
Eclipse help documents are now created when calling the 'make all' target on the dev-manual. Resulting files are archived into the tarball as well. When calling 'make clean' artefacts of the eclipse documentation build are deleted. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation/Makefile')
-rw-r--r--documentation/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/documentation/Makefile b/documentation/Makefile
index 417e511991..810d3f08cc 100644
--- a/documentation/Makefile
+++ b/documentation/Makefile
@@ -85,7 +85,7 @@ endif
ifeq ($(DOC),dev-manual)
XSLTOPTS = --xinclude
-ALLPREQ = html pdf tarball
+ALLPREQ = html pdf eclipse tarball
#
# Note that the tarfile might produce the "Cannot stat: No such file or directory" error
# message for .PNG files that are not present when building a particular branch. The
@@ -116,10 +116,11 @@ TARFILES = dev-style.css dev-manual.html dev-manual.pdf \
figures/app-dev-flow.png figures/bsp-dev-flow.png figures/dev-title.png \
figures/git-workflow.png figures/index-downloads.png figures/kernel-dev-flow.png \
figures/kernel-overview-1.png figures/kernel-overview-2-generic.png \
- figures/source-repos.png figures/yp-download.png
+ figures/source-repos.png figures/yp-download.png \
+ eclipse
endif
-MANUALS = $(DOC)/$(DOC).html $(DOC)/$(DOC).pdf
+MANUALS = $(DOC)/$(DOC).html $(DOC)/$(DOC).pdf $(DOC)/eclipse
FIGURES = figures
STYLESHEET = $(DOC)/*.css