summaryrefslogtreecommitdiffstats
path: root/documentation/Makefile
diff options
context:
space:
mode:
authorScott Rifenbark <srifenbark@gmail.com>2018-01-03 16:09:41 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-14 15:25:27 +0000
commitbc6a19d6a765dbc91c090cabddb6dd968378237d (patch)
tree2bc9dcc8c60de05f33cba4270c50211339d1d97b /documentation/Makefile
parent9f478d13585ca0ae129ffdb71a1b68b0202a2465 (diff)
downloadopenembedded-core-contrib-bc6a19d6a765dbc91c090cabddb6dd968378237d.tar.gz
overview-manual: Added new "overview" manual to YP doc set
Fixes [YOCTO #12370] I added all the mechanics for this new "Yocto Project Overview Manual". For now, the manual builds and publishes into the 2.5 area. I used "overview-manual" for the folder name. Makefile properly builds the new manual. The mega-manual.sed file processes links for the new manual. The mega-manual.xml file includes the new manual. The poky.ent file includes a new ENTITY link for the overview manual. All pieces are in place. With this commit, just an overview chapter exists. The remaining content needs to be developed. (From yocto-docs rev: 632ebd4a91920585e736527e070ca8363a00f41b) Signed-off-by: Scott Rifenbark <srifenbark@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation/Makefile')
-rw-r--r--documentation/Makefile17
1 files changed, 15 insertions, 2 deletions
diff --git a/documentation/Makefile b/documentation/Makefile
index a747b44738..c6584af546 100644
--- a/documentation/Makefile
+++ b/documentation/Makefile
@@ -84,6 +84,17 @@
# for the 'denzil' branch.
#
+ifeq ($(DOC),overview-manual)
+XSLTOPTS = --xinclude
+ALLPREQ = html eclipse tarball
+TARFILES = overview-style.css overview-manual.html figures/overview-title.png \
+ eclipse
+MANUALS = $(DOC)/$(DOC).html $(DOC)/eclipse
+FIGURES = figures
+STYLESHEET = $(DOC)/*.css
+
+endif
+
ifeq ($(DOC),bsp-guide)
XSLTOPTS = --xinclude
ALLPREQ = html eclipse tarball
@@ -249,7 +260,8 @@ TARFILES = mega-manual.html mega-style.css \
figures/sdk-environment.png figures/sdk-installed-standard-sdk-directory.png \
figures/sdk-devtool-add-flow.png figures/sdk-installed-extensible-sdk-directory.png \
figures/sdk-devtool-modify-flow.png figures/sdk-eclipse-dev-flow.png \
- figures/sdk-devtool-upgrade-flow.png figures/bitbake-build-flow.png figures/ypqs-title.png
+ figures/sdk-devtool-upgrade-flow.png figures/bitbake-build-flow.png figures/ypqs-title.png \
+ figures/overview-title.png
endif
MANUALS = $(DOC)/$(DOC).html
@@ -406,10 +418,11 @@ eclipse: eclipse-generate eclipse-resolve-links
.PHONY : eclipse-generate eclipse-resolve-links
eclipse-generate:
-ifeq ($(filter $(DOC), sdk-manual bsp-guide dev-manual kernel-dev profile-manual ref-manual yocto-project-qs),)
+ifeq ($(filter $(DOC), overview-manual sdk-manual bsp-guide dev-manual kernel-dev profile-manual ref-manual yocto-project-qs),)
@echo " "
@echo "ERROR: You can only create eclipse documentation"
@echo " of the following documentation parts:"
+ @echo " - overview-manual"
@echo " - sdk-manual"
@echo " - bsp-guide"
@echo " - dev-manual"