aboutsummaryrefslogtreecommitdiffstats
path: root/documentation/Makefile
diff options
context:
space:
mode:
authorScott Rifenbark <scott.m.rifenbark@intel.com>2012-01-24 21:27:11 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-08 12:07:44 -0800
commite66c7a5ceea519160fd384bc568828d17c80e78b (patch)
tree82610bd47a42f69351304fa22c9f0ee3ea3c3fce /documentation/Makefile
parentf8d248e946c07cb20b9f567966b388cac604e362 (diff)
downloadopenembedded-core-contrib-e66c7a5ceea519160fd384bc568828d17c80e78b.tar.gz
documentation/Makefile: fixes for missing tarfiles
I had added some edison-specific figures and they needed to be included in the TARFILE variable for the YP development manual. The fix now makes the TARFILE variable all-inclusive for all .PNG files regardless of branch. Consequently, there can be some missing files when the manual is made but the errors are okay. I documented the exceptions above the variable. (From yocto-docs rev: 500d4102c5496cb834b93378242599715810386a) Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation/Makefile')
-rw-r--r--documentation/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/documentation/Makefile b/documentation/Makefile
index 21ffc50f37..02fe0a3e95 100644
--- a/documentation/Makefile
+++ b/documentation/Makefile
@@ -66,10 +66,18 @@ XSLTOPTS = --stringparam html.stylesheet style.css \
--stringparam section.label.includes.component.label 1 \
--xinclude
ALLPREQ = html pdf tarball
-TARFILES = style.css dev-manual.html dev-manual.pdf figures/bsp-dev-flow.png figures/dev-title.png \
+#
+# Note that the tarfile might produce the "Cannot stat: No such file or directory" error
+# message for .PNG files that are not present when building a particular branch. The
+# list of files is all-inclusive for all branches.
+#
+TARFILES = style.css dev-manual.html dev-manual.pdf \
+ figures/app-dev-flow.png figures/bsp-dev-flow.png figures/dev-title.png \
figures/git-workflow.png figures/index-downloads.png figures/kernel-dev-flow.png \
- figures/kernel-example-repos.png figures/kernel-overview-1.png figures/kernel-overview-2.png \
- figures/kernel-overview-3.png figures/source-repos.png figures/yp-download.png \
+ figures/kernel-example-repos.png figures/kernel-example-repos-edison.png \
+ figures/kernel-overview-1.png figures/kernel-overview-2.png \
+ figures/kernel-overview-3.png figures/kernel-overview-3-edison.png \
+ figures/source-repos.png figures/yp-download.png \
figures/wip.png
MANUALS = $(DOC)/$(DOC).html $(DOC)/$(DOC).pdf
FIGURES = figures