aboutsummaryrefslogtreecommitdiffstats
path: root/documentation/Makefile
diff options
context:
space:
mode:
authorTimo Mueller <timo.mueller@bmw-carit.de>2013-02-08 09:16:33 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-14 17:25:35 +0000
commita41a805500cab281fba15bd8e5d3e60b88d0d4be (patch)
tree9973678912b57cfdef5b1f9676794a556b4d8966 /documentation/Makefile
parent768152340898cbb9faed6e8865a4e35c69833230 (diff)
downloadopenembedded-core-contrib-a41a805500cab281fba15bd8e5d3e60b88d0d4be.tar.gz
documentation: Part 1 of 2 updates to integrating docs to Eclipse help.
Hi, the generation of eclipse help files has been merged from the timo branch to the master. Since the creation of the timo branch there have been some changes to the master branch (e.g. new documentation, renamed documentation). This patch set does some cleanup for the renamed documentation and adds eclipse help generation support to the new documentation. 01: Removes the 'the' from the document titles 02..04: Cleanup obsolete artifacts resulting from the merge 05..08: Add eclipse help generation for ref-manual 09..13: Add eclipse help generation for kernel-dev 14..18: Add eclipse help generation for profile-manual Best regards, Timo This patch set originally contained 18 patches. I (Scott Rifenbark) had to push these changes as two parts. This is the first part. It does not include creation of the three cusomization files. (From yocto-docs rev: 9b1889f6e31ee70dae704fa08763fb9196616dad) Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation/Makefile')
-rw-r--r--documentation/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/documentation/Makefile b/documentation/Makefile
index 2668f31f0b..5272ee58bd 100644
--- a/documentation/Makefile
+++ b/documentation/Makefile
@@ -227,13 +227,8 @@ STYLESHEET = $(DOC)/*.css
endif
ifeq ($(DOC),profile-manual)
-XSLTOPTS = --stringparam html.stylesheet profile-manual-style.css \
- --stringparam chapter.autolabel 1 \
- --stringparam appendix.autolabel A \
- --stringparam section.autolabel 1 \
- --stringparam section.label.includes.component.label 1 \
- --xinclude
-ALLPREQ = html pdf tarball
+XSLTOPTS = --xinclude
+ALLPREQ = html pdf eclipse tarball
TARFILES = profile-manual.html profile-manual.pdf profile-manual-style.css \
figures/profile-title.png figures/kernelshark-all.png \
figures/kernelshark-choose-events.png figures/kernelshark-i915-display.png \
@@ -323,9 +318,17 @@ eclipse: eclipse-generate eclipse-resolve-links
.PHONY : eclipse-generate eclipse-resolve-links
eclipse-generate:
-ifeq ($(DOC),mega-manual)
+ifeq ($(filter $(DOC), adt-manual bsp-guide dev-manual kernel-dev profile-manual ref-manual yocto-project-qs),)
@echo " "
- @echo "ERROR: You cannot generate eclipse documentation for the mega-manual"
+ @echo "ERROR: You can only create eclipse documentation"
+ @echo " of the following documentation parts:"
+ @echo " - adt-manual"
+ @echo " - bsp-guide"
+ @echo " - dev-manual"
+ @echo " - kernel-dev"
+ @echo " - profile-manual"
+ @echo " - ref-manual"
+ @echo " - yocto-project-qs"
@echo " "
else
@echo " "