aboutsummaryrefslogtreecommitdiffstats
path: root/documentation/Makefile
diff options
context:
space:
mode:
authorScott Rifenbark <srifenbark@gmail.com>2015-12-28 11:49:01 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-07 12:13:45 +0000
commit8bdc7071ee4c7edb6ec6bf1eb08407d9d97ee0e4 (patch)
tree8ed0a9377fe3d90dd6be4971d1a0cef65243e995 /documentation/Makefile
parentf1f7625f713c39a67db39db8873a63bdde56eced (diff)
downloadopenembedded-core-contrib-8bdc7071ee4c7edb6ec6bf1eb08407d9d97ee0e4.tar.gz
sdk-manual: Initial Manual framework
Makefile - Added support for new sdk-manual. mega-manual - Added the sdk-title.png file to the list of figures. Modified to support inclusion of the new sdk-manual into the mega-manual. poky.ent - Added a new string to support the new sdk-manual. sdk-manual - Created new sdk-title.png image. Created new sdk-manual.xml file. Created sdk-manual customization layers for both standard build and Eclipse build. Note that we are pointing to local XSL templates for and these will change going forward. Created new sdk-style.css file. Created three chapter files that are placeholders at this point. (From yocto-docs rev: ab591831a97a97d405d13ed75e9fb01e0452c292) Signed-off-by: Scott Rifenbark <srifenbark@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation/Makefile')
-rw-r--r--documentation/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/documentation/Makefile b/documentation/Makefile
index 99adea2fe6..6c2f466036 100644
--- a/documentation/Makefile
+++ b/documentation/Makefile
@@ -198,7 +198,7 @@ TARFILES = mega-manual.html mega-style.css figures/yocto-environment.png \
figures/using-a-pre-built-image.png \
figures/poky-title.png figures/buildhistory.png \
figures/buildhistory-web.png \
- figures/adt-title.png figures/bsp-title.png \
+ figures/adt-title.png figures/sdk-title.png figures/bsp-title.png \
figures/kernel-dev-title.png figures/kernel-architecture-overview.png \
figures/app-dev-flow.png figures/bsp-dev-flow.png \
figures/dev-title.png \
@@ -280,6 +280,16 @@ FIGURES = figures
STYLESHEET = $(DOC)/*.css
endif
+ifeq ($(DOC),sdk-manual)
+XSLTOPTS = --xinclude
+ALLPREQ = html eclipse tarball
+TARFILES = sdk-manual.html sdk-style.css figures/sdk-title.png \
+ eclipse
+MANUALS = $(DOC)/$(DOC).html $(DOC)/eclipse
+FIGURES = figures
+STYLESHEET = $(DOC)/*.css
+endif
+
ifeq ($(DOC),profile-manual)
XSLTOPTS = --xinclude
ALLPREQ = html eclipse tarball
@@ -394,10 +404,11 @@ eclipse: eclipse-generate eclipse-resolve-links
.PHONY : eclipse-generate eclipse-resolve-links
eclipse-generate:
-ifeq ($(filter $(DOC), adt-manual bsp-guide dev-manual kernel-dev profile-manual ref-manual yocto-project-qs),)
+ifeq ($(filter $(DOC), adt-manual sdk-manual bsp-guide dev-manual kernel-dev profile-manual ref-manual yocto-project-qs),)
@echo " "
@echo "ERROR: You can only create eclipse documentation"
@echo " of the following documentation parts:"
+ @echo " - sdk-manual"
@echo " - adt-manual"
@echo " - bsp-guide"
@echo " - dev-manual"