aboutsummaryrefslogtreecommitdiffstats
path: root/documentation/Makefile
diff options
context:
space:
mode:
authorTimo Mueller <timo.mueller@bmw-carit.de>2012-11-30 09:59:21 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-14 15:21:49 +0000
commit733a44d048a0fbd1ef8de68cb92888bdc7ea1636 (patch)
treed421b2c2126c7c9282ce849bbf7e13ed03b27e75 /documentation/Makefile
parent2586bd854ca8d73765927bb211e4cadc26116565 (diff)
downloadopenembedded-core-contrib-733a44d048a0fbd1ef8de68cb92888bdc7ea1636.tar.gz
documentation/Makefile: Support for making Eclipse HTML adt manual
This target will generate eclipse help for the adt-manual using the adt-manual-eclipse-customization.xsl stylesheet. The output will be generated to a separate directory which can be used for integrating the documentation into eclipse. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation/Makefile')
-rw-r--r--documentation/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/documentation/Makefile b/documentation/Makefile
index 6020800230..903f5917e1 100644
--- a/documentation/Makefile
+++ b/documentation/Makefile
@@ -326,6 +326,29 @@ else
endif
+eclipse: BASE_DIR = html/$(DOC)/
+
+eclipse:
+ifneq ($(DOC),adt-manual)
+ @echo " "
+ @echo "ERROR: You can only create eclipse documentation of the"
+ @echo " Yocto Project Application Development Toolkit (ADT)"
+ @echo " User's Guide"
+ @echo " "
+else
+ @echo " "
+ @echo "******** Building eclipse help of "$(DOC)
+ @echo " "
+ cd $(DOC) && \
+ xsltproc $(XSLTOPTS) \
+ --stringparam base.dir '$(BASE_DIR)' \
+ -o eclipse/$(DOC).html \
+ $(DOC)-eclipse-customization.xsl $(DOC).xml && \
+ mv eclipse/toc.xml eclipse/$(DOC)-toc.xml && \
+ cp -rf $(FIGURES) eclipse/$(BASE_DIR)/$(FIGURES) && \
+ cd ..
+endif
+
tarball: html
@echo " "
@echo "******** Creating Tarball of document files"