aboutsummaryrefslogtreecommitdiffstats
path: root/documentation/Makefile
diff options
context:
space:
mode:
authorScott Rifenbark <scott.m.rifenbark@intel.com>2011-08-29 05:46:52 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-30 17:27:38 +0100
commit2b3563fca83391017b8eb8d7c84a7981ad29381d (patch)
treee941f1ece4c34ff2e9c1675edf54cb508387074b /documentation/Makefile
parentd67201e6003ad2be8ebcd9aaca9c8212cf8ca007 (diff)
downloadopenembedded-core-contrib-2b3563fca83391017b8eb8d7c84a7981ad29381d.tar.gz
documentation/Makefile: Updated comments for usage per Robert P. J. Day
Robert Day correctly pointed out that the usage comments in the Makefile were not exactly accurate. The VER argument is necessary only if you are going to publish a document to the YP website. I updated the usage comments accordingly. (From yocto-docs rev: dd033227af0f88e45b539b92be8f1321fcd4f975) Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation/Makefile')
-rw-r--r--documentation/Makefile23
1 files changed, 15 insertions, 8 deletions
diff --git a/documentation/Makefile b/documentation/Makefile
index 176f38ee0e..0acb53db7c 100644
--- a/documentation/Makefile
+++ b/documentation/Makefile
@@ -17,17 +17,20 @@
# The command-line argument DOC represents the folder name in which a particular
# document is stored. The command-line argument VER represents the distro
# version of the Yocto Release for which the manuals are being generated.
-# You must invoke the Makefile with the DOC and VER arguments.
+# To build the HTML and PDF versions of the manual you must invoke the Makefile
+# with the DOC argument. If you are going to publish the manual then you
+# you must invoke the Makefile with both the DOC and the VER argument.
+#
# Examples:
#
-# make DOC=bsp-guide VER=1.1
-# make DOC=yocto-project-qs VER=1.1
-# make pdf DOC=yocto-project-qs VER=1.1
+# make DOC=bsp-guide
+# make DOC=yocto-project-qs
+# make pdf DOC=poky-ref-manual
#
-# The first example generates the HTML and PDF versions of the BSP Guide for
-# the Yocto Project 1.1 Release. The second example generates the HTML version
-# of the Quick Start. The third example generates an error because you cannot
-# generate a PDF version of the Quick Start.
+# The first example generates the HTML and PDF versions of the BSP Guide.
+# The second example generates the HTML version only of the Quick Start. Note that
+# the Quick Start only has an HTML version available. The third example generates
+# both the PDF and HTML versions of the Yocto Project Reference Manual.
#
# Use the publish target to push the generated manuals to the Yocto Project
# website. All files needed for the manual's HTML form are pushed as well as the
@@ -37,6 +40,10 @@
# make publish DOC=bsp-guide VER=1.1
# make publish DOC=adt-manual VER=1.1
#
+# The first example publishes the 1.1 version of both the PDF and HTML versions of
+# the BSP Guide. The second example publishes the 1.1 version of both the PDF and
+# HTML versions of the ADT Manual.
+#
ifeq ($(DOC),bsp-guide)
XSLTOPTS = --stringparam html.stylesheet style.css \