aboutsummaryrefslogtreecommitdiffstats
path: root/documentation/Makefile
diff options
context:
space:
mode:
authorScott Rifenbark <scott.m.rifenbark@intel.com>2013-01-16 12:37:54 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-27 13:54:09 +0000
commit9bd5435f6f05b8ab9c01f5e353d7bc2426712301 (patch)
tree3697767be12f1230680a2a5b098decbb3a42449e /documentation/Makefile
parent33b7996446dd5408d56787c62ae452eae8ab2492 (diff)
downloadopenembedded-core-contrib-9bd5435f6f05b8ab9c01f5e353d7bc2426712301.tar.gz
Makefile: Added support for the new profile-manual.
(From yocto-docs rev: 09183423d3049b954b0f0a5d882bf85218b5aff9) Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'documentation/Makefile')
-rw-r--r--documentation/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/documentation/Makefile b/documentation/Makefile
index 13a70a0e8d..3f0ceed368 100644
--- a/documentation/Makefile
+++ b/documentation/Makefile
@@ -221,6 +221,36 @@ FIGURES = figures
STYLESHEET = $(DOC)/*.css
endif
+ifeq ($(DOC),profile-manual)
+XSLTOPTS = --stringparam html.stylesheet profile-manual-style.css \
+ --stringparam chapter.autolabel 1 \
+ --stringparam appendix.autolabel A \
+ --stringparam section.autolabel 1 \
+ --stringparam section.label.includes.component.label 1 \
+ --xinclude
+ALLPREQ = html pdf tarball
+TARFILES = profile-manual.html profile-manual.pdf profile-manual-style.css \
+ figures/profile-title.png figures/kernelshark-all.png \
+ figures/kernelshark-choose-events.png figures/kernelshark-i915-display.png \
+ figures/kernelshark-output-display.png figures/lttngmain0.png \
+ figures/oprofileui-busybox.png figures/oprofileui-copy-to-user.png \
+ figures/oprofileui-downloading.png figures/oprofileui-processes.png \
+ figures/perf-probe-do_fork-profile.png figures/perf-report-cycles-u.png \
+ figures/perf-systemwide.png figures/perf-systemwide-libc.png \
+ figures/perf-wget-busybox-annotate-menu.png figures/perf-wget-busybox-annotate-udhcpc.png \
+ figures/perf-wget-busybox-debuginfo.png figures/perf-wget-busybox-dso-zoom.png \
+ figures/perf-wget-busybox-dso-zoom-menu.png figures/perf-wget-busybox-expanded-stripped.png \
+ figures/perf-wget-flat-stripped.png figures/perf-wget-g-copy-from-user-expanded-stripped.png \
+ figures/perf-wget-g-copy-to-user-expanded-debuginfo.png figures/perf-wget-g-copy-to-user-expanded-stripped.png \
+ figures/perf-wget-g-copy-to-user-expanded-stripped-unresolved-hidden.png figures/pybootchartgui-linux-yocto.png \
+ figures/pychart-linux-yocto-rpm.png figures/pychart-linux-yocto-rpm-nostrip.png \
+ figures/sched-wakeup-profile.png figures/sysprof-callers.png \
+ figures/sysprof-copy-from-user.png figures/sysprof-copy-to-user.png
+MANUALS = $(DOC)/$(DOC).html $(DOC)/$(DOC).pdf
+FIGURES = figures
+STYLESHEET = $(DOC)/*.css
+endif
+
ifeq ($(DOC),kernel-manual)
XSLTOPTS = --stringparam html.stylesheet kernel-style.css \
--stringparam chapter.autolabel 1 \