summaryrefslogtreecommitdiffstats
path: root/bitbake
diff options
context:
space:
mode:
authorScott Rifenbark <srifenbark@gmail.com>2019-04-18 10:37:07 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-04-23 16:34:03 +0100
commitf0d4ef3cdcf803aab2acf3c40dea8bfec44dc01c (patch)
treeb9b1c57d66937a99fef8bdec95c4c5dc10e5c2d2 /bitbake
parentc23c8ebc7f66a92110bfc9e3c4d633a432d1353b (diff)
downloadopenembedded-core-contrib-f0d4ef3cdcf803aab2acf3c40dea8bfec44dc01c.tar.gz
bitbake: bitbake-user-manual: Added section on modifying variables
Fixes [YOCTO #12548] I created a new section titled "Modifying Variable Values" that provides instruction on how to use the "bitbake -e" command to be sure your configuration and variable values are as expected. (Bitbake rev: 5a697957d7687fe2c730896e178f7e1e054fe724) Signed-off-by: Scott Rifenbark <srifenbark@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'bitbake')
-rw-r--r--bitbake/doc/bitbake-user-manual/bitbake-user-manual-metadata.xml72
1 files changed, 72 insertions, 0 deletions
diff --git a/bitbake/doc/bitbake-user-manual/bitbake-user-manual-metadata.xml b/bitbake/doc/bitbake-user-manual/bitbake-user-manual-metadata.xml
index 199ab23095..a125ad332e 100644
--- a/bitbake/doc/bitbake-user-manual/bitbake-user-manual-metadata.xml
+++ b/bitbake/doc/bitbake-user-manual/bitbake-user-manual-metadata.xml
@@ -61,6 +61,78 @@
</para>
</section>
+ <section id='modifying-existing-variables'>
+ <title>Modifying Existing Variables</title>
+
+ <para>
+ Sometimes you need to modify existing variables.
+ Following are some cases where you might find you want to
+ modify an existing variable:
+ <itemizedlist>
+ <listitem><para>
+ Customize a recipe that uses the variable.
+ </para></listitem>
+ <listitem><para>
+ Change a variable's default value used in a
+ <filename>*.bbclass</filename> file.
+ </para></listitem>
+ <listitem><para>
+ Change the variable in a <filename>*.bbappend</filename>
+ file to override the variable in the original recipe.
+ </para></listitem>
+ <listitem><para>
+ Change the variable in a configuration file so that the
+ value overrides an existing configuration.
+ </para></listitem>
+ </itemizedlist>
+ </para>
+
+ <para>
+ Changing a variable value can sometimes depend on how the
+ value was originally assigned and also on the desired
+ intent of the change.
+ In particular, when you append a value to a variable that
+ has a default value, the resulting value might not be what
+ you expect.
+ In this case, the value you provide might replace the value
+ rather than append to the default value.
+ </para>
+
+ <para>
+ If after you have changed a variable's value and something
+ unexplained occurs, you can use BitBake to check the actual
+ value of the suspect variable.
+ You can make these checks for both configuration and recipe
+ level changes:
+ <itemizedlist>
+ <listitem><para>
+ For configuration changes, use the following:
+ <literallayout class='monospaced'>
+ $ bitbake -e
+ </literallayout>
+ This command displays variable values after the
+ configuration files (i.e. <filename>local.conf</filename>,
+ <filename>bblayers.conf</filename>,
+ <filename>bitbake.conf</filename> and so forth) have
+ been parsed.
+ <note>
+ Variables that are exported to the environment are
+ preceded by the string "export" in the command's
+ output.
+ </note>
+ </para></listitem>
+ <listitem><para>
+ For recipe changes, use the following:
+ <literallayout class='monospaced'>
+ $ bitbake <replaceable>recipe</replaceable> -e | grep VARIABLE="
+ </literallayout>
+ This command checks to see if the variable actually
+ makes it into a specific recipe.
+ </para></listitem>
+ </itemizedlist>
+ </para>
+ </section>
+
<section id='line-joining'>
<title>Line Joining</title>