aboutsummaryrefslogtreecommitdiffstats
path: root/bitbake
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-09-30 20:46:17 +0000
committerRichard Purdie <richard@openedhand.com>2008-09-30 20:46:17 +0000
commit221ac2b25f544a500869667d8f95c6c12c80db1a (patch)
treecb14f631faeb933c4dc0e52aee2c1b383bb2da4d /bitbake
parentdc98b2c28c0a7a7ea715230a234bb846a18e4584 (diff)
downloadopenembedded-core-contrib-221ac2b25f544a500869667d8f95c6c12c80db1a.tar.gz
bitbake/bitbake-dev: Sync with upstream
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5346 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'bitbake')
-rw-r--r--bitbake/ChangeLog2
-rwxr-xr-xbitbake/bin/bitbake2
-rw-r--r--bitbake/lib/bb/cooker.py4
-rw-r--r--bitbake/lib/bb/parse/parse_py/ConfHandler.py1
-rw-r--r--bitbake/lib/bb/utils.py1
5 files changed, 9 insertions, 1 deletions
diff --git a/bitbake/ChangeLog b/bitbake/ChangeLog
index c4aa5ba198..a2d0da29ea 100644
--- a/bitbake/ChangeLog
+++ b/bitbake/ChangeLog
@@ -52,6 +52,8 @@ Changes in BitBake 1.8.x:
- Raise an exception if SRCREV == 'INVALID'
- Fix hg fetcher username/password handling and fix crash
- Fix PACKAGES_DYNAMIC handling of packages with '++' in the name
+ - Rename __depends to __base_depends after configuration parsing so we don't
+ recheck the validity of the config files time after time
Changes in BitBake 1.8.10:
- Psyco is available only for x86 - do not use it on other architectures.
diff --git a/bitbake/bin/bitbake b/bitbake/bin/bitbake
index 4492bf045b..e262d0b9b4 100755
--- a/bitbake/bin/bitbake
+++ b/bitbake/bin/bitbake
@@ -113,6 +113,8 @@ Default BBFILES are the .bb files in the current directory.""" )
cooker = bb.cooker.BBCooker(configuration)
+ cooker.parseConfiguration()
+
if configuration.profile:
try:
import cProfile as profile
diff --git a/bitbake/lib/bb/cooker.py b/bitbake/lib/bb/cooker.py
index 8e6acb19fc..50624d8d33 100644
--- a/bitbake/lib/bb/cooker.py
+++ b/bitbake/lib/bb/cooker.py
@@ -59,6 +59,10 @@ class BBCooker:
self.configuration.data = bb.data.init()
+ def parseConfiguration(self):
+
+ bb.data.inheritFromOS(self.configuration.data)
+
for f in self.configuration.file:
self.parseConfigurationFile( f )
diff --git a/bitbake/lib/bb/parse/parse_py/ConfHandler.py b/bitbake/lib/bb/parse/parse_py/ConfHandler.py
index e6488bbe11..f8a49689e2 100644
--- a/bitbake/lib/bb/parse/parse_py/ConfHandler.py
+++ b/bitbake/lib/bb/parse/parse_py/ConfHandler.py
@@ -118,7 +118,6 @@ def handle(fn, data, include = 0):
init(data)
if include == 0:
- bb.data.inheritFromOS(data)
oldfile = None
else:
oldfile = bb.data.getVar('FILE', data)
diff --git a/bitbake/lib/bb/utils.py b/bitbake/lib/bb/utils.py
index 211ac8129f..9c8d8e8435 100644
--- a/bitbake/lib/bb/utils.py
+++ b/bitbake/lib/bb/utils.py
@@ -305,3 +305,4 @@ def prunedir(topdir):
for name in dirs:
os.rmdir(os.path.join(root, name))
os.rmdir(topdir)
+