aboutsummaryrefslogtreecommitdiffstats
path: root/bitbake
diff options
context:
space:
mode:
authorEd Bartosh <ed.bartosh@linux.intel.com>2016-06-07 16:37:25 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-15 08:35:05 +0100
commit4422d26dd6e13f271852a9285f6c1cf90d689f26 (patch)
treec74e0e8f76ba08d137b87eebaf982ae2a42af79d /bitbake
parentc28f918e5d0df775324da965f03b354a83e78920 (diff)
downloadopenembedded-core-contrib-4422d26dd6e13f271852a9285f6c1cf90d689f26.tar.gz
bitbake: toaster: fix incorrect file mode
Python 3 complains about 'wa' mode this way: ValueError: must have exactly one of create/read/write/append mode Fixed by using 'a' mode. [YOCTO #9584] (Bitbake rev: eb23a84e079125a08d0c8e910f7035ad9584c432) Signed-off-by: Ed Bartosh <ed.bartosh@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'bitbake')
-rw-r--r--bitbake/lib/toaster/toastergui/tests.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/bitbake/lib/toaster/toastergui/tests.py b/bitbake/lib/toaster/toastergui/tests.py
index 722b383509..31f1431ea3 100644
--- a/bitbake/lib/toaster/toastergui/tests.py
+++ b/bitbake/lib/toaster/toastergui/tests.py
@@ -304,7 +304,7 @@ class ViewTests(TestCase):
"""Download the recipe file generated for the custom image"""
# Create a dummy recipe file for the custom image generation to read
- open("/tmp/a_recipe.bb", 'wa').close()
+ open("/tmp/a_recipe.bb", 'a').close()
response = self.client.get(reverse('customrecipedownload',
args=(self.project.id,
self.customr.id)))