aboutsummaryrefslogtreecommitdiffstats
path: root/bitbake
diff options
context:
space:
mode:
authorBelen Barros Pena <belen.barros.pena@linux.intel.com>2016-04-28 13:45:17 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-15 08:35:03 +0100
commit6f924f394acda5e79f5377f4aab8fb6cb052545a (patch)
tree106d4f76f7d6521a258cbeae99ccee192ca79944 /bitbake
parentabfd095a05f70e1f2a80c6491d2a5d19593d4824 (diff)
downloadopenembedded-core-contrib-6f924f394acda5e79f5377f4aab8fb6cb052545a.tar.gz
bitbake: toaster: tweaks to recipe file downloads
* In the custom images table, show the recipe file and download icon only when the recipe file exists and can be downloaded. * Also in the custom images table, make sure the download icon tooltip shows on hover. * In the custom image details page, show the correct icon (download) next to the recipe file in the right hand column. * In the custom image details page, show the recipe file and download icon in the right hand column only when the recipe file exists and can be downloaded * Also in the custom image details page, simplify the help text we show when the 'download' button is disabled: it gave so much information about what's actually happening under the hood that it was a bit hard to follow. (Bitbake rev: 5d4172bc005efe209de595f6a151ae9ed062d051) Signed-off-by: Belen Barros Pena <belen.barros.pena@linux.intel.com> Signed-off-by: Elliot Smith <elliot.smith@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'bitbake')
-rw-r--r--bitbake/lib/toaster/toastergui/tables.py7
-rw-r--r--bitbake/lib/toaster/toastergui/templates/customrecipe.html8
2 files changed, 6 insertions, 9 deletions
diff --git a/bitbake/lib/toaster/toastergui/tables.py b/bitbake/lib/toaster/toastergui/tables.py
index caa2fba51a..2bbef637aa 100644
--- a/bitbake/lib/toaster/toastergui/tables.py
+++ b/bitbake/lib/toaster/toastergui/tables.py
@@ -495,12 +495,9 @@ class CustomImagesTable(ToasterTable):
static_data_template=name_link_template)
recipe_file_template = '''
- <code>{{data.name}}_{{data.version}}.bb</code>
{% if data.get_base_recipe_file %}
- <a href="{% url 'customrecipedownload' extra.pid data.pk %}">
- <i class="icon-download-alt" data-original-title="Download recipe
- file"></i>
- </a>
+ <code>{{data.name}}_{{data.version}}.bb</code>
+ <a href="{% url 'customrecipedownload' extra.pid data.pk %}" class="icon-download-alt get-help" title="Download recipe file"></a>
{% endif %}'''
self.add_column(title="Recipe file",
diff --git a/bitbake/lib/toaster/toastergui/templates/customrecipe.html b/bitbake/lib/toaster/toastergui/templates/customrecipe.html
index aeb4466a20..4b1ef6617f 100644
--- a/bitbake/lib/toaster/toastergui/templates/customrecipe.html
+++ b/bitbake/lib/toaster/toastergui/templates/customrecipe.html
@@ -107,7 +107,7 @@
Download recipe file
{% if not base_recipe_file %}
<i class="icon-question-sign get-help"
- data-original-title="The {{recipe.name}} recipe cannot yet be downloaded as the Based on recipe '{{recipe.base_recipe.name}}' has not yet been fetched"></i>
+ data-original-title="The recipe file doesn't exist yet, so you cannot download it. You need to build your custom image first"></i>
{% endif %}
</a>
</div>
@@ -182,13 +182,13 @@
</dd>
{% endwith %}
{% endif %}
+ {% if base_recipe_file %}
<dt>Recipe file</dt>
<dd>
<code>{{recipe.name}}_{{recipe.version}}.bb</code>
- {% if base_recipe_path %}
- <a href="{% url 'customrecipedownload' project.pk recipe.pk %}"><i class="icon-share" title="" data-original-title="View recipe file"></i></a>
- {% endif %}
+ <a href="{% url 'customrecipedownload' project.pk recipe.pk %}"><i class="icon-download-alt" title="Download recipe file"></i></a>
</dd>
+ {% endif %}
<dt>Layer</dt>
<dd><a href="{% url 'layerdetails' project.id recipe.layer_version.pk %}">{{recipe.layer_version.layer.name}}</a></dd>
{% if recipe.summary %}