summaryrefslogtreecommitdiffstats
path: root/bitbake/lib/bb/command.py
diff options
context:
space:
mode:
authorCristiana Voicu <cristiana.voicu@intel.com>2013-07-29 10:02:24 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-06 13:02:24 +0100
commit564c83be5ee1f69e6d097c20dbfa3a76cccc0aa0 (patch)
tree75ee8ffa60e28f9275ff7b5d2b32bb97e2c3b2b4 /bitbake/lib/bb/command.py
parent140744c4701bcac0dd61e11303d008f2ea34fc1b (diff)
downloadopenembedded-core-contrib-564c83be5ee1f69e6d097c20dbfa3a76cccc0aa0.tar.gz
bitbake: hob/bitbake: save the description of a custom image
When an new image is saved, the dialog for this action has a field for the description. Changed how an image is saved, by appending the DESCRIPTION variable at the end of the .bb file. [YOCTO #4193] (Bitbake rev: 5629007f2b984005e3a8ac5d9b71422cbc2f1409) Signed-off-by: Cristiana Voicu <cristiana.voicu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'bitbake/lib/bb/command.py')
-rw-r--r--bitbake/lib/bb/command.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/bitbake/lib/bb/command.py b/bitbake/lib/bb/command.py
index 1893cce71e..5eb34aff3d 100644
--- a/bitbake/lib/bb/command.py
+++ b/bitbake/lib/bb/command.py
@@ -215,8 +215,9 @@ class CommandsSync:
base_image = params[1]
package_queue = params[2]
timestamp = params[3]
+ description = params[4]
return command.cooker.generateNewImage(image, base_image,
- package_queue, timestamp)
+ package_queue, timestamp, description)
def ensureDir(self, command, params):
directory = params[0]