summaryrefslogtreecommitdiffstats
path: root/bitbake/bin
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-04-01 15:04:49 +0000
committerRichard Purdie <richard@openedhand.com>2007-04-01 15:04:49 +0000
commit7371e6323c3fb6b0545712e3cf84606644073e77 (patch)
treee08f25669ec0f0e9d11334909f3b68c0ab6aca19 /bitbake/bin
parent8b36dc217443aeeec8493d39561d2bb010336774 (diff)
downloadopenembedded-core-contrib-7371e6323c3fb6b0545712e3cf84606644073e77.tar.gz
bitbake: Update to 1.8.1 (inc. various bug fixes, epoch support)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1419 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'bitbake/bin')
-rwxr-xr-xbitbake/bin/bitbake14
1 files changed, 4 insertions, 10 deletions
diff --git a/bitbake/bin/bitbake b/bitbake/bin/bitbake
index 001f229331..70a862a815 100755
--- a/bitbake/bin/bitbake
+++ b/bitbake/bin/bitbake
@@ -27,7 +27,7 @@ sys.path.insert(0,os.path.join(os.path.dirname(os.path.dirname(sys.argv[0])), 'l
import bb
from bb import cooker
-__version__ = "1.7.4"
+__version__ = "1.8.1"
#============================================================================#
# BBOptions
@@ -109,15 +109,9 @@ Default BBFILES are the .bb files in the current directory.""" )
configuration.pkgs_to_build = []
configuration.pkgs_to_build.extend(args[1:])
- bb.cooker.BBCooker().cook(configuration)
+ cooker = bb.cooker.BBCooker(configuration)
+ cooker.cook()
+
if __name__ == "__main__":
main()
- sys.exit(0)
- import profile
- profile.run('main()', "profile.log")
- import pstats
- p = pstats.Stats('profile.log')
- p.sort_stats('time')
- p.print_stats()
- p.print_callers()