aboutsummaryrefslogtreecommitdiffstats
path: root/bitbake-dev/bin
diff options
context:
space:
mode:
authorRobert Bradford <rob@openedhand.com>2008-10-17 09:46:59 +0000
committerRobert Bradford <rob@openedhand.com>2008-10-17 09:46:59 +0000
commitbd63867cbe48eab91523731def4cec80187b5c0f (patch)
treeadf7665910884f47a227f03db5f1577844574c09 /bitbake-dev/bin
parent39ad2b3120e50e8c88d03fcd323f2369ffbfe850 (diff)
downloadopenembedded-core-contrib-bd63867cbe48eab91523731def4cec80187b5c0f.tar.gz
bitbake-dev: Move the ncurses TTY check into the UI plugin itself.
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5529 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'bitbake-dev/bin')
-rwxr-xr-xbitbake-dev/bin/bitbake5
1 files changed, 0 insertions, 5 deletions
diff --git a/bitbake-dev/bin/bitbake b/bitbake-dev/bin/bitbake
index 87284c08fe..ea4147e971 100755
--- a/bitbake-dev/bin/bitbake
+++ b/bitbake-dev/bin/bitbake
@@ -123,7 +123,6 @@ Default BBFILES are the .bb files in the current directory.""" )
configuration.pkgs_to_build = []
configuration.pkgs_to_build.extend(args[1:])
-
# Work out which UI(s) to use
curseUI = False
depexplorerUI = False
@@ -168,10 +167,6 @@ Default BBFILES are the .bb files in the current directory.""" )
# Launch the UI
try:
- # Disable UIs that need a terminal
- if not os.isatty(sys.stdout.fileno()):
- curseUI = False
-
if curseUI:
try:
import curses